summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pluggaloid/pluggaloid-1.1.2.ebuild')
-rw-r--r--dev-ruby/pluggaloid/pluggaloid-1.1.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/pluggaloid/pluggaloid-1.1.2.ebuild b/dev-ruby/pluggaloid/pluggaloid-1.1.2.ebuild
new file mode 100644
index 000000000000..56d0bd4fe5a6
--- /dev/null
+++ b/dev-ruby/pluggaloid/pluggaloid-1.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+DESCRIPTION="Pluggaloid is extensible plugin system for mikutter"
+HOMEPAGE="https://rubygems.org/gems/pluggaloid/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/delayer
+ dev-ruby/instance_storage:0
+"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile test/*_test.rb || die
+}