summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rake/rake-10.4.0.ebuild')
-rw-r--r--dev-ruby/rake/rake-10.4.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-ruby/rake/rake-10.4.0.ebuild b/dev-ruby/rake/rake-10.4.0.ebuild
new file mode 100644
index 000000000000..93f91da72540
--- /dev/null
+++ b/dev-ruby/rake/rake-10.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc TODO"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="Make-like scripting in Ruby"
+HOMEPAGE="https://github.com/jimweirich/rake"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND+=" app-arch/gzip"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.4 )"
+
+all_ruby_prepare() {
+ # Decompress the file. The compressed version has errors, ignore them.
+ zcat doc/rake.1.gz > doc/rake.1
+}
+
+all_ruby_compile() {
+ if use doc; then
+ rdoc --title "Rake - Ruby Make" --main README.rdoc --out html lib *.rdoc doc/*/*.rdoc || die
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'gem "minitest", "~>5.4"; require "minitest/autorun"; Dir["test/test_*.rb"].each{|f| require f}' || die
+}
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper rake
+
+ if use doc; then
+ pushd html
+ dohtml -r *
+ popd
+ fi
+
+ doman doc/rake.1
+
+ newbashcomp "${FILESDIR}"/rake.bash-completion ${PN}
+}