summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-augeas/ruby-augeas-0.5.0-r2.ebuild')
-rw-r--r--dev-ruby/ruby-augeas/ruby-augeas-0.5.0-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/ruby-augeas/ruby-augeas-0.5.0-r2.ebuild b/dev-ruby/ruby-augeas/ruby-augeas-0.5.0-r2.ebuild
new file mode 100644
index 000000000000..f9aafa5b706a
--- /dev/null
+++ b/dev-ruby/ruby-augeas/ruby-augeas-0.5.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# jruby -> native extentions
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_DOCDIR="doc/site/api"
+RUBY_FAKEGEM_EXTRADOC="NEWS README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby bindings for Augeas"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="http://download.augeas.net/ruby/${P}.gem"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 hppa ia64 ppc sparc x86"
+IUSE=""
+
+RDEPEND=">=app-admin/augeas-1.1.0"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+each_ruby_configure() {
+ ${RUBY} -C ext/augeas extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/augeas V=1
+}
+
+each_ruby_install() {
+ mv ext/augeas/_augeas$(get_modname) lib/ || die
+
+ each_fakegem_install
+}