summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/shoulda')
-rw-r--r--dev-ruby/shoulda/Manifest2
-rw-r--r--dev-ruby/shoulda/metadata.xml8
-rw-r--r--dev-ruby/shoulda/shoulda-2.11.3-r1.ebuild28
-rw-r--r--dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild28
-rw-r--r--dev-ruby/shoulda/shoulda-3.5.0-r1.ebuild34
5 files changed, 100 insertions, 0 deletions
diff --git a/dev-ruby/shoulda/Manifest b/dev-ruby/shoulda/Manifest
new file mode 100644
index 000000000000..e96068476c27
--- /dev/null
+++ b/dev-ruby/shoulda/Manifest
@@ -0,0 +1,2 @@
+DIST shoulda-2.11.3.tar.gz 145068 SHA256 8ab7e93f93d75c72cd5b8e84805b5c5b2e5f66e0b1cff933f8890ea203fff614 SHA512 0b347c4a8be177b5806364114c25dc786ca2ac95a11c93a723dbc9ea1f6d8ae62df7fb420a52d477cd1e10e8d894074072a040eef36ee8a43440e5256c8427e4 WHIRLPOOL 84d6cde1b3dc47d6a536b3125219432d4e7ece6d4cf3904adacbbc4866de9357f45fde44d7738820ca2a14dc4291322f98c8153029d288a77a9221c9e92b2ce7
+DIST shoulda-3.5.0.tar.gz 7149 SHA256 79adabf8f57b9b2fd890039b2f85a93a8d8cd2119cfa49611b1798f27d54b0a3 SHA512 41fe41ab1fcd3dd1b2ebde1163cb0712f4cd2615fea9cd2ad6fbd6de46cca8039db94fb91ce1850e84632dbfc299692a728ec91e7c0fbf2d9050fa2c1ee98933 WHIRLPOOL 434654a74290d6f1c44bd7ea980aa539582ac0368a844e20b4f333f2669f41e8e9e039e72c594e4bc20d49bf20b339b11e92a03419aee07b255d2ab161baf238
diff --git a/dev-ruby/shoulda/metadata.xml b/dev-ruby/shoulda/metadata.xml
new file mode 100644
index 000000000000..4cba2872be95
--- /dev/null
+++ b/dev-ruby/shoulda/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">thoughtbot/shoulda</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/shoulda/shoulda-2.11.3-r1.ebuild b/dev-ruby/shoulda/shoulda-2.11.3-r1.ebuild
new file mode 100644
index 000000000000..6198d82f5042
--- /dev/null
+++ b/dev-ruby/shoulda/shoulda-2.11.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTION_GUIDELINES.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+SRC_URI="https://github.com/thoughtbot/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+RUBY_S="thoughtbot-${PN}-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# tests seem to be quite broken :( They require working version of
+# various rails versions. There appear to be unit and matcher tests but
+# they can't be run on their own.
+RESTRICT=test
diff --git a/dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild b/dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild
new file mode 100644
index 000000000000..76e867a93e4c
--- /dev/null
+++ b/dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+# Use rdoc recipe to avoid obsolete Rakefile
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTION_GUIDELINES.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+SRC_URI="https://github.com/thoughtbot/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+RUBY_S="thoughtbot-${PN}-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# tests seem to be quite broken :( They require working version of
+# various rails versions. There appear to be unit and matcher tests but
+# they can't be run on their own.
+RESTRICT=test
diff --git a/dev-ruby/shoulda/shoulda-3.5.0-r1.ebuild b/dev-ruby/shoulda/shoulda-3.5.0-r1.ebuild
new file mode 100644
index 000000000000..d1692250da25
--- /dev/null
+++ b/dev-ruby/shoulda/shoulda-3.5.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+SRC_URI="https://github.com/thoughtbot/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64"
+IUSE=""
+
+# This now more or less a meta-gem and it only contains features for
+# integration tests using Appraisals, which we don't currently package.
+RESTRICT=test
+
+ruby_add_rdepend ">=dev-ruby/shoulda-context-1.0.1
+ >=dev-ruby/shoulda-matchers-1.4.1"
+
+all_ruby_prepare() {
+ sed -e '/git ls-files/d' -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}