summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/simple_oauth/simple_oauth-0.3.0.ebuild')
-rw-r--r--dev-ruby/simple_oauth/simple_oauth-0.3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/simple_oauth/simple_oauth-0.3.0.ebuild b/dev-ruby/simple_oauth/simple_oauth-0.3.0.ebuild
new file mode 100644
index 000000000000..52bb5544fdbb
--- /dev/null
+++ b/dev-ruby/simple_oauth/simple_oauth-0.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simply builds and verifies OAuth headers"
+HOMEPAGE="https://github.com/laserlemon/simple_oauth"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+all_ruby_prepare() {
+ sed -i -e "/simplecov/,+8d" spec/helper.rb || die
+}
+each_ruby_test() {
+ export CI=true
+ each_fakegem_test
+}