summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/termcolor/termcolor-1.2.2.ebuild')
-rw-r--r--dev-ruby/termcolor/termcolor-1.2.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/termcolor/termcolor-1.2.2.ebuild b/dev-ruby/termcolor/termcolor-1.2.2.ebuild
new file mode 100644
index 000000000000..526f03f1bc9b
--- /dev/null
+++ b/dev-ruby/termcolor/termcolor-1.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#*** Using highline effectively in JRuby requires manually installing the ffi-ncurses gem.
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="a library for ANSI color formatting like HTML for output in terminal"
+HOMEPAGE="http://termcolor.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/highline-1.5.0"