summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tidy-ext')
-rw-r--r--dev-ruby/tidy-ext/Manifest1
-rw-r--r--dev-ruby/tidy-ext/metadata.xml8
-rw-r--r--dev-ruby/tidy-ext/tidy-ext-0.1.14-r1.ebuild39
-rw-r--r--dev-ruby/tidy-ext/tidy-ext-0.1.14-r2.ebuild39
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-ruby/tidy-ext/Manifest b/dev-ruby/tidy-ext/Manifest
new file mode 100644
index 000000000000..6089628106e9
--- /dev/null
+++ b/dev-ruby/tidy-ext/Manifest
@@ -0,0 +1 @@
+DIST tidy-ext-0.1.14.gem 260608 SHA256 9bd24274b4fea9f2c459a34742b89f106f03ac34086db2119b779b3190109344 SHA512 8a8eada3cb5e815338de49332a24c85b9b2cabba0e10f2d72fe85bd4faf76924e52d82066e7b73e62bc459631aaa9d1c42a6941988ae2a71ca0ddd4f3302ad86 WHIRLPOOL 1c228aebe12ce1f425d1e2545d5f10e75444a9dc4138629d7e398c2d929d72cd0cb8b00629a10079db8423dd94e937f0bda59b00ce675ac97829e5e5f28ac58b
diff --git a/dev-ruby/tidy-ext/metadata.xml b/dev-ruby/tidy-ext/metadata.xml
new file mode 100644
index 000000000000..5adefb6e43ed
--- /dev/null
+++ b/dev-ruby/tidy-ext/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">carld/tidy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/tidy-ext/tidy-ext-0.1.14-r1.ebuild b/dev-ruby/tidy-ext/tidy-ext-0.1.14-r1.ebuild
new file mode 100644
index 000000000000..735ab1ce75d1
--- /dev/null
+++ b/dev-ruby/tidy-ext/tidy-ext-0.1.14-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="W3C HTML Tidy library implemented as a Ruby extension"
+HOMEPAGE="http://github.com/carld/tidy"
+
+LICENSE="HTML-Tidy"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+all_ruby_prepare() {
+ mkdir lib || die
+
+ # Remove reference to rspec 1
+ sed -i -e '/spec/d' spec/spec_helper.rb || die
+
+ # Avoid spec that needs network connectivity.
+ rm spec/tidy/remote_uri_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/tidy extconf.rb || die "Unable to configure extension."
+}
+
+each_ruby_compile() {
+ emake -Cext/tidy V=1
+ cp ext/tidy/tidy$(get_modname) lib/ || die "Unable to copy extension."
+}
diff --git a/dev-ruby/tidy-ext/tidy-ext-0.1.14-r2.ebuild b/dev-ruby/tidy-ext/tidy-ext-0.1.14-r2.ebuild
new file mode 100644
index 000000000000..84ff6a775098
--- /dev/null
+++ b/dev-ruby/tidy-ext/tidy-ext-0.1.14-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="W3C HTML Tidy library implemented as a Ruby extension"
+HOMEPAGE="http://github.com/carld/tidy"
+
+LICENSE="HTML-Tidy"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ mkdir lib || die
+
+ # Remove reference to rspec 1
+ sed -i -e '/spec/d' spec/spec_helper.rb || die
+
+ # Avoid spec that needs network connectivity.
+ rm spec/tidy/remote_uri_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/tidy extconf.rb || die "Unable to configure extension."
+}
+
+each_ruby_compile() {
+ emake -Cext/tidy V=1
+ cp ext/tidy/tidy$(get_modname) lib/ || die "Unable to copy extension."
+}