summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/timers/timers-4.0.1.ebuild')
-rw-r--r--dev-ruby/timers/timers-4.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/timers/timers-4.0.1.ebuild b/dev-ruby/timers/timers-4.0.1.ebuild
new file mode 100644
index 000000000000..33b904bf3c56
--- /dev/null
+++ b/dev-ruby/timers/timers-4.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pure Ruby one-shot and periodic timers"
+HOMEPAGE="https://github.com/tarcieri/timers"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/hitimes"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/coveralls/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/Coveralls/ s:^:#:' spec/spec_helper.rb || die
+
+ # Remove performance spec due to dependencies and being to dependent
+ # on machine specifics.
+ rm spec/performance_spec.rb
+
+ # Remove rspec3 configuration so we can still run with rspec2.
+ sed -e '/expose/ s:^:#:' -i spec/spec_helper.rb || die
+}