summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/uconv/uconv-0.6.1-r2.ebuild')
-rw-r--r--dev-ruby/uconv/uconv-0.6.1-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/uconv/uconv-0.6.1-r2.ebuild b/dev-ruby/uconv/uconv-0.6.1-r2.ebuild
new file mode 100644
index 000000000000..b820e5f9e416
--- /dev/null
+++ b/dev-ruby/uconv/uconv-0.6.1-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+inherit ruby-ng
+
+DESCRIPTION="A module to convert ISO/IEC 10646 (Unicode) string and Japanese strings"
+HOMEPAGE="http://www.yoshidam.net/Ruby.html#uconv"
+SRC_URI="http://www.yoshidam.net/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S=${PN}
+
+all_ruby_prepare() {
+ sed -i -e '/^\$CFLAGS = ""/d' extconf.rb || die "Unable to remove CFLAGS line"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_install() {
+ emake V=1 DESTDIR="${D}" install
+}
+
+all_ruby_install() {
+ dodoc README*
+}