summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/vagrant_cloud/vagrant_cloud-2.0.1.ebuild')
-rw-r--r--dev-ruby/vagrant_cloud/vagrant_cloud-2.0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/vagrant_cloud/vagrant_cloud-2.0.1.ebuild b/dev-ruby/vagrant_cloud/vagrant_cloud-2.0.1.ebuild
new file mode 100644
index 000000000000..941860ed0cd3
--- /dev/null
+++ b/dev-ruby/vagrant_cloud/vagrant_cloud-2.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Vagrant Cloud API Library"
+HOMEPAGE="https://github.com/hashicorp/vagrant_cloud"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rest-client-2.0.2"
+ruby_add_bdepend ">=dev-ruby/rake-10.4
+ test? ( >=dev-ruby/webmock-3.0 )"
+
+all_ruby_prepare() {
+ sed -i -e '/rubocop/I s:^:#:' Rakefile || die
+}