summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/will_paginate/will_paginate-3.1.5.ebuild')
-rw-r--r--dev-ruby/will_paginate/will_paginate-3.1.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/will_paginate/will_paginate-3.1.5.ebuild b/dev-ruby/will_paginate/will_paginate-3.1.5.ebuild
new file mode 100644
index 000000000000..4a59d88c0349
--- /dev/null
+++ b/dev-ruby/will_paginate/will_paginate-3.1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Most awesome pagination solution for Ruby"
+HOMEPAGE="https://github.com/mislav/will_paginate/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~x86-macos"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '1igem "rails", "<5"' spec/spec_helper.rb || die
+
+ # Remove tests for unpackaged ORMs
+ rm -f spec/finders/{sequel,mongoid,data_mapper}* || die
+}
+
+ruby_add_bdepend "
+ test? (
+ <dev-ruby/rails-5
+ dev-ruby/mocha
+ )"