summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-json_expectations/Manifest1
-rw-r--r--dev-ruby/rspec-json_expectations/metadata.xml11
-rw-r--r--dev-ruby/rspec-json_expectations/rspec-json_expectations-2.1.0.ebuild32
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/rspec-json_expectations/Manifest b/dev-ruby/rspec-json_expectations/Manifest
new file mode 100644
index 000000000000..df7ddd792b6d
--- /dev/null
+++ b/dev-ruby/rspec-json_expectations/Manifest
@@ -0,0 +1 @@
+DIST rspec-json_expectations-2.1.0.gem 14848 SHA256 76593bd2025d076df534e18ff7b08e2cb117fb57637c2ecef3fc97b4e6866d50 SHA512 1b09b959d6ecbc76c13b37fbf89cba381feb00505ce3a5701ad87ef1ed2ee178ea760508af809ac7dc8285c24d86dd7e33a7fb903a7f74472ca59d59f8df0daf WHIRLPOOL 8498611f5c9ad2af2181d0051702be36cc45e774cad6d93d8676a37c553451c4aa48cd1a8a62c4d41e3f01df4b68cdd054e4d74ce6f08b858a260de9aef3fce8
diff --git a/dev-ruby/rspec-json_expectations/metadata.xml b/dev-ruby/rspec-json_expectations/metadata.xml
new file mode 100644
index 000000000000..3d3fa1d37b90
--- /dev/null
+++ b/dev-ruby/rspec-json_expectations/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">waterlink/rspec-json_expectations</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.1.0.ebuild b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.1.0.ebuild
new file mode 100644
index 000000000000..3543a798501a
--- /dev/null
+++ b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Set of matchers and helpers to allow you test your APIs responses."
+HOMEPAGE="https://github.com/waterlink/rspec-json_expectations"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+all_ruby_prepare() {
+ sed -i -e '1irequire "forwardable"' lib/rspec/json_expectations/matchers.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S cucumber --format progress features || die
+}