summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/bibtexu/bibtexu-3.71_p20120701.ebuild')
-rw-r--r--dev-tex/bibtexu/bibtexu-3.71_p20120701.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-tex/bibtexu/bibtexu-3.71_p20120701.ebuild b/dev-tex/bibtexu/bibtexu-3.71_p20120701.ebuild
new file mode 100644
index 000000000000..00d2b5df46ca
--- /dev/null
+++ b/dev-tex/bibtexu/bibtexu-3.71_p20120701.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="8-bit Implementation of BibTeX 0.99 with a Very Large Capacity"
+HOMEPAGE="http://tug.org/texlive/"
+SRC_URI="mirror://gentoo/texlive-${PV#*_p}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/kpathsea-6.1.0_p20120701
+ >=dev-libs/icu-4.4:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
+
+src_configure() {
+ econf \
+ --with-system-kpathsea \
+ --with-system-icu
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ csfdir="${EPREFIX}/usr/share/texmf-dist/bibtexu/csf/base" \
+ btdocdir="${EPREFIX}/usr/share/doc/${PF}" \
+ install || die
+ dodoc 00readme.txt ChangeLog csfile.txt HISTORY
+}