summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/metapost')
-rw-r--r--dev-tex/metapost/Manifest3
-rw-r--r--dev-tex/metapost/files/invocname.patch13
-rw-r--r--dev-tex/metapost/metadata.xml5
-rw-r--r--dev-tex/metapost/metapost-1.780.ebuild74
-rw-r--r--dev-tex/metapost/metapost-1.803.ebuild74
-rw-r--r--dev-tex/metapost/metapost-1.902.ebuild77
6 files changed, 246 insertions, 0 deletions
diff --git a/dev-tex/metapost/Manifest b/dev-tex/metapost/Manifest
new file mode 100644
index 000000000000..50d94eb9938c
--- /dev/null
+++ b/dev-tex/metapost/Manifest
@@ -0,0 +1,3 @@
+DIST metapost-1.780-src.tar.bz2 7723409 SHA256 aca382bb1c6b4f52d389c0170cad57c4961fa8de634de34ea47b0a37cfabde58 SHA512 3002da0706fcd33a2d183f42b770b7c2d72759a8ba0e49ae24e4a5cee5dd9cd0842e7e8d854e22962beaff4dfd1b943a63f41ee07a7743bb7d50a0cdfb4dd4ff WHIRLPOOL 3095ac3cda9bd65487074882c6cc9d8bf2210d04b69ed741290054f1622a5c29ce9af986cc5b819b910db2757eb14565e1ce9a1968a2f29ae72bca50ce2c90d1
+DIST metapost-1.803-src.tar.bz2 8140579 SHA256 436c57c8f8753b6829a1df575cbc3af553b6df42c51abd5c420117ad4c6cdeb3 SHA512 7f59e93f73c9f9c6fe547028dd22527c948ea171c235758e1acf9477c85d2fb2cc145b3bd707646a4b5317e57ce5d49160ff347cdecca599b6e0da8a8f679d99 WHIRLPOOL cc999052d994f8d1c21c1a843696097cca10ae4fd794a761a916618021dc9e1dd300305c220b30da8de1f2a8b7c35a91dfc22da8666d366e01948d0e34edfdb3
+DIST metapost-1.902-src.tar.bz2 6170876 SHA256 3e26ec212e0cbd29c6c38985026c8c229df6432c7066f2c7e9c1fbec1f0dda9d SHA512 d1e38d9f6f16b6815999c1d05b70ece50668962660af0800c105075522a2d943156986aa8df76d7bd2b6d04f657295c15a04a6e67772ce1d8546b885c355aea3 WHIRLPOOL 0f15cfe404cf42e534111fa88832e7ed62d59b68f14bd18961f8fa55ede9ad4c0debb4acae22af2fda780b72e0812e4f2285435dec299d17a18604aa30ac1b9f
diff --git a/dev-tex/metapost/files/invocname.patch b/dev-tex/metapost/files/invocname.patch
new file mode 100644
index 000000000000..f269957c2b2f
--- /dev/null
+++ b/dev-tex/metapost/files/invocname.patch
@@ -0,0 +1,13 @@
+Index: source/texk/web2c/lib/setupvar.c
+===================================================================
+--- source/texk/web2c/lib/setupvar.c (revision 21623)
++++ source/texk/web2c/lib/setupvar.c (revision 21624)
+@@ -23,7 +23,7 @@
+ if (conf_val < 0 || (conf_val == 0 && dflt > 0)) {
+ fprintf (stderr,
+ "%s: Bad value (%ld) in texmf.cnf for %s, keeping %ld.\n",
+- program_invocation_name,
++ kpse_invocation_name,
+ (long) conf_val, var_name, (long) dflt);
+ } else {
+ *var = conf_val; /* We'll make further checks later. */
diff --git a/dev-tex/metapost/metadata.xml b/dev-tex/metapost/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/dev-tex/metapost/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>
diff --git a/dev-tex/metapost/metapost-1.780.ebuild b/dev-tex/metapost/metapost-1.780.ebuild
new file mode 100644
index 000000000000..3e04839c74e8
--- /dev/null
+++ b/dev-tex/metapost/metapost-1.780.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="System for producing graphics"
+HOMEPAGE="http://tug.org/metapost.html"
+SRC_URI="http://foundry.supelec.fr/gf/download/frsrelease/395/1879/${P}-src.tar.bz2"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/kpathsea
+ >=app-eselect/eselect-mpost-0.3
+ x11-libs/cairo
+ x11-libs/pixman
+ media-libs/libpng"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P}/source/texk/web2c
+
+src_configure() {
+ econf \
+ --disable-all-pkgs \
+ --enable-shared \
+ --disable-largefile \
+ --disable-ptex \
+ --enable-mp \
+ --with-system-cairo \
+ --with-system-libpng \
+ --without-ptexenc \
+ --with-system-kpathsea \
+ --with-system-xpdf \
+ --with-system-freetype \
+ --with-system-freetype2 \
+ --with-system-gd \
+ --with-system-teckit \
+ --with-system-t1lib \
+ --with-system-icu \
+ --with-system-graphite \
+ --with-system-zziplib \
+ --with-system-poppler \
+ --with-system-zlib \
+ --with-system-pixman \
+ --disable-native-texlive-build \
+ --without-mf-x-toolkit --without-x
+}
+
+src_compile() {
+ emake mpost
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ SUBDIRS="" \
+ bin_PROGRAMS="mpost" \
+ nodist_man_MANS="" \
+ dist_man_MANS="" \
+ install-binPROGRAMS
+ # Rename it
+ mv "${D}/usr/bin/mpost" "${D}/usr/bin/mpost-${P}" || die "renaming failed"
+
+ cd "${WORKDIR}/${P}"
+ dodoc README CHANGES
+}
+
+pkg_postinst(){
+ einfo "Calling eselect mpost update"
+ eselect mpost update
+}
diff --git a/dev-tex/metapost/metapost-1.803.ebuild b/dev-tex/metapost/metapost-1.803.ebuild
new file mode 100644
index 000000000000..841442d8415f
--- /dev/null
+++ b/dev-tex/metapost/metapost-1.803.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="System for producing graphics"
+HOMEPAGE="http://tug.org/metapost.html"
+SRC_URI="https://foundry.supelec.fr/frs/download.php/file/15750/${P}-src.tar.bz2"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-libs/kpathsea-6.1.0_p20120701
+ >=app-eselect/eselect-mpost-0.3
+ >=x11-libs/cairo-1.12
+ >x11-libs/pixman-0.18
+ media-libs/libpng:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P}/source/texk/web2c
+
+src_configure() {
+ econf \
+ --disable-all-pkgs \
+ --enable-shared \
+ --disable-largefile \
+ --disable-ptex \
+ --enable-mp \
+ --with-system-cairo \
+ --with-system-libpng \
+ --without-ptexenc \
+ --with-system-kpathsea \
+ --with-system-xpdf \
+ --with-system-freetype \
+ --with-system-freetype2 \
+ --with-system-gd \
+ --with-system-teckit \
+ --with-system-t1lib \
+ --with-system-icu \
+ --with-system-graphite \
+ --with-system-zziplib \
+ --with-system-poppler \
+ --with-system-zlib \
+ --with-system-pixman \
+ --disable-native-texlive-build \
+ --without-mf-x-toolkit --without-x
+}
+
+src_compile() {
+ emake mpost
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ SUBDIRS="" \
+ bin_PROGRAMS="mpost" \
+ nodist_man_MANS="" \
+ dist_man_MANS="" \
+ install-binPROGRAMS
+ # Rename it
+ mv "${D}/usr/bin/mpost" "${D}/usr/bin/mpost-${P}" || die "renaming failed"
+
+ cd "${WORKDIR}/${P}"
+ dodoc README CHANGES
+}
+
+pkg_postinst(){
+ einfo "Calling eselect mpost update"
+ eselect mpost update
+}
diff --git a/dev-tex/metapost/metapost-1.902.ebuild b/dev-tex/metapost/metapost-1.902.ebuild
new file mode 100644
index 000000000000..6a3ebd9783ca
--- /dev/null
+++ b/dev-tex/metapost/metapost-1.902.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="System for producing graphics"
+HOMEPAGE="http://tug.org/metapost.html"
+SRC_URI="https://foundry.supelec.fr/frs/download.php/file/15766/${P}-src.tar.bz2"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-libs/kpathsea-6.1.0_p20120701
+ >=app-eselect/eselect-mpost-0.3
+ >=x11-libs/cairo-1.12
+ >x11-libs/pixman-0.18
+ media-libs/libpng:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P}/source/texk/web2c
+
+src_configure() {
+ has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ econf \
+ --disable-all-pkgs \
+ --enable-shared \
+ --disable-largefile \
+ --disable-ptex \
+ --enable-mp \
+ --with-system-cairo \
+ --with-system-libpng \
+ --without-ptexenc \
+ --with-system-kpathsea \
+ --with-system-xpdf \
+ --with-system-freetype \
+ --with-system-freetype2 \
+ --with-system-gd \
+ --with-system-teckit \
+ --with-system-t1lib \
+ --with-system-icu \
+ --with-system-graphite \
+ --with-system-zziplib \
+ --with-system-poppler \
+ --with-system-zlib \
+ --with-system-pixman \
+ --disable-native-texlive-build \
+ --without-mf-x-toolkit --without-x
+}
+
+src_compile() {
+ emake mpost
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ SUBDIRS="" \
+ bin_PROGRAMS="mpost" \
+ nodist_man_MANS="" \
+ dist_man_MANS="" \
+ install-binPROGRAMS
+ # Rename it
+ mv "${D}/usr/bin/mpost" "${D}/usr/bin/mpost-${P}" || die "renaming failed"
+
+ cd "${WORKDIR}/${P}"
+ dodoc README CHANGES
+}
+
+pkg_postinst(){
+ einfo "Calling eselect mpost update"
+ eselect mpost update
+}