summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/pstplus/pstplus-1.6.ebuild')
-rw-r--r--dev-tex/pstplus/pstplus-1.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-tex/pstplus/pstplus-1.6.ebuild b/dev-tex/pstplus/pstplus-1.6.ebuild
new file mode 100644
index 000000000000..a6b3e8f2e6d4
--- /dev/null
+++ b/dev-tex/pstplus/pstplus-1.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils qt4-r2
+
+DESCRIPTION="A PSTricks GUI"
+HOMEPAGE="http://www.xm1math.net/pstplus/"
+SRC_URI="http://www.xm1math.net/pstplus/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtgui:4
+ dev-qt/qtcore:4
+ app-text/poppler[qt4]"
+RDEPEND="${DEPEND}
+ virtual/latex-base
+ dev-texlive/texlive-pstricks
+ app-text/psutils
+ sci-visualization/gnuplot
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+
+DOCS="utilities/AUTHORS"
+
+src_install() {
+ qt4-r2_src_install
+
+ newicon utilities/pstplus48x48.png pstplus.png
+ make_desktop_entry pstplus Pstplus "pstplus" Office
+}
+
+pkg_postinst() {
+ elog "Examples are available at:"
+ elog "/usr/share/${PN}/"
+}