summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bless/files')
-rw-r--r--dev-util/bless/files/bless-0.6.0-mono-4.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/bless/files/bless-0.6.0-mono-4.patch b/dev-util/bless/files/bless-0.6.0-mono-4.patch
new file mode 100644
index 000000000000..92b1100cf0e7
--- /dev/null
+++ b/dev-util/bless/files/bless-0.6.0-mono-4.patch
@@ -0,0 +1,36 @@
+diff --git a/builder/ModuleBuilder.cs b/builder/ModuleBuilder.cs
+index 0f62e92..7edb1ab 100644
+--- a/builder/ModuleBuilder.cs
++++ b/builder/ModuleBuilder.cs
+@@ -119,7 +119,7 @@ public class ModuleBuilder
+ //System.Console.WriteLine("gmcs {0}", sb.ToString());
+ System.Console.WriteLine(">> Building module {0}...", module.Name);
+
+- Process buildProcess = Process.Start("gmcs", sb.ToString());
++ Process buildProcess = Process.Start("mcs", sb.ToString());
+ buildProcess.WaitForExit();
+
+ if (buildProcess.ExitCode == 0) {
+@@ -137,4 +137,4 @@ public class ModuleBuilder
+ }
+
+
+-}
+\ No newline at end of file
++}
+diff --git a/configure.ac b/configure.ac
+index 415cc64..a8e527c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -24,9 +24,9 @@ if test "x$PKG_CONFIG" = "xno"; then
+ fi
+
+ # C# compiler
+-AC_PATH_PROG(MCS, gmcs, no)
++AC_PATH_PROG(MCS, mcs, no)
+
+-CS="gmcs C#"
++CS="mcs C#"
+ if test "x$MCS" = "xno" ; then
+ AC_MSG_ERROR([No $CS compiler found])
+ fi