summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/codeblocks/codeblocks-13.12.ebuild')
-rw-r--r--dev-util/codeblocks/codeblocks-13.12.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/codeblocks/codeblocks-13.12.ebuild b/dev-util/codeblocks/codeblocks-13.12.ebuild
new file mode 100644
index 000000000000..bfc98340429e
--- /dev/null
+++ b/dev-util/codeblocks/codeblocks-13.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+WX_GTK_VER="2.8"
+
+inherit eutils wxwidgets
+
+DESCRIPTION="The open source, cross platform, free C++ IDE"
+HOMEPAGE="http://www.codeblocks.org/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+SRC_URI="mirror://sourceforge/codeblocks/${P/-/_}-1.tar.gz"
+
+IUSE="contrib debug pch static-libs"
+
+RDEPEND="app-arch/zip
+ x11-libs/wxGTK:2.8[X]
+ contrib? (
+ app-text/hunspell
+ dev-libs/boost:=
+ dev-libs/libgamin
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-wx-config="${WX_CONFIG}" \
+ $(use_enable debug) \
+ $(use_enable pch) \
+ $(use_enable static-libs static) \
+ $(use_with contrib contrib-plugins all)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}