summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/debootstrap/debootstrap-1.0.72.ebuild')
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.72.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/debootstrap/debootstrap-1.0.72.ebuild b/dev-util/debootstrap/debootstrap-1.0.72.ebuild
new file mode 100644
index 000000000000..b1d33cf3ffbf
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.72.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="http://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+
+DOCS=( TODO debian/changelog )
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring"
+ elog " (--keyring=K), please install app-crypt/gnupg."
+ fi
+}