summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/geany/geany-1.33.ebuild')
-rw-r--r--dev-util/geany/geany-1.33.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/dev-util/geany/geany-1.33.ebuild b/dev-util/geany/geany-1.33.ebuild
new file mode 100644
index 000000000000..4975465aee2a
--- /dev/null
+++ b/dev-util/geany/geany-1.33.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils xdg-utils
+
+LANGS="ar ast be bg ca cs de el en_GB es et eu fa fi fr gl he hi hu id it ja kk ko lb lt mn nl nn pl pt pt_BR ro ru sk sl sr sv tr uk vi zh_CN ZH_TW"
+NOSHORTLANGS="en_GB zh_CN zh_TW"
+
+DESCRIPTION="GTK+ based fast and lightweight IDE"
+HOMEPAGE="http://www.geany.org"
+if [[ "${PV}" = 9999* ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/geany/geany.git"
+else
+ SRC_URI="http://download.geany.org/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
+LICENSE="GPL-2+ HPND"
+SLOT="0"
+
+IUSE="gtk3 +vte"
+
+RDEPEND=">=dev-libs/glib-2.32:2
+ !gtk3? (
+ >=x11-libs/gtk+-2.24:2
+ vte? ( x11-libs/vte:0 )
+ )
+ gtk3? (
+ >=x11-libs/gtk+-3.0:3
+ vte? ( x11-libs/vte:2.91 )
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ strip-linguas ${LANGS}
+}
+
+src_prepare() {
+ default
+
+ # Syntax highlighting for Portage
+ sed -i -e "s:*.sh;:*.sh;*.ebuild;*.eclass;:" \
+ data/filetype_extensions.conf || die
+
+ if [[ ${PV} = *_pre* ]] || [[ ${PV} = 9999* ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-html-docs
+ --disable-dependency-tracking
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable gtk3)
+ $(use_enable vte)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files --all
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}