summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/igprof')
-rw-r--r--dev-util/igprof/Manifest1
-rw-r--r--dev-util/igprof/igprof-5.9.11.ebuild27
-rw-r--r--dev-util/igprof/metadata.xml10
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/igprof/Manifest b/dev-util/igprof/Manifest
new file mode 100644
index 000000000000..963b6823596d
--- /dev/null
+++ b/dev-util/igprof/Manifest
@@ -0,0 +1 @@
+DIST igprof-5.9.11.tar.gz 174304 SHA256 af65c7f8ba12730d1e362155c46856b2241c15e0113a2211bb4e75b47b851065 SHA512 1c6a16e286243a997b9ce798f2403597e1d8178a7b4652e38e9afbcd48c84d868dc83ddee7eb76243096f21b9cd9c0337641bba840008c24429e60454cff1444 WHIRLPOOL 88a67dae1b9344c790814dab853303e9d7ded8e23054e1ca74c90c39d8cd8365de47587a152bc64f93aa2ee62e69d5a969fcf4049268d806e3a298bd30461289
diff --git a/dev-util/igprof/igprof-5.9.11.ebuild b/dev-util/igprof/igprof-5.9.11.ebuild
new file mode 100644
index 000000000000..f89b0361356c
--- /dev/null
+++ b/dev-util/igprof/igprof-5.9.11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Ignominous Profiler for analysing application memory and performance characteristics"
+HOMEPAGE="http://igprof.org"
+SRC_URI="http://github.com/ktf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# pcre is automagic dependency, let's make it unoptional
+# libatomic_ops is listed as dependency, but isn't actually used by package
+DEPEND="dev-libs/libpcre
+ sys-libs/libunwind"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e 's/-Werror//g' -i CMakeLists.txt
+ cmake-utils_src_prepare
+}
diff --git a/dev-util/igprof/metadata.xml b/dev-util/igprof/metadata.xml
new file mode 100644
index 000000000000..603285e3a421
--- /dev/null
+++ b/dev-util/igprof/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ktf/igprof</remote-id>
+ </upstream>
+</pkgmetadata>