summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/kcov/kcov-40.ebuild')
-rw-r--r--dev-util/kcov/kcov-40.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-util/kcov/kcov-40.ebuild b/dev-util/kcov/kcov-40.ebuild
index 963a9c930a5e..ea93aa899477 100644
--- a/dev-util/kcov/kcov-40.ebuild
+++ b/dev-util/kcov/kcov-40.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{9,10} )
inherit cmake python-any-r1
DESCRIPTION="Kcov is a code coverage tester for compiled languages, Python and Bash"
@@ -27,6 +27,11 @@ RDEPEND="dev-libs/elfutils
DEPEND="${RDEPEND}"
BDEPEND="${PYTHON_DEPS}"
+PATCHES=(
+ "${FILESDIR}"/${P}-binutils-2.39.patch
+ "${FILESDIR}"/${P}-gcc-13.patch
+)
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Bfd=$(usex !binutils)