summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/makepp')
-rw-r--r--dev-util/makepp/Manifest3
-rw-r--r--dev-util/makepp/files/makepp-1.18-install.patch69
-rw-r--r--dev-util/makepp/makepp-1.18.ebuild37
-rw-r--r--dev-util/makepp/makepp-2.0.99.2.ebuild (renamed from dev-util/makepp/makepp-2.0.99.1.ebuild)11
-rw-r--r--dev-util/makepp/metadata.xml7
5 files changed, 9 insertions, 118 deletions
diff --git a/dev-util/makepp/Manifest b/dev-util/makepp/Manifest
index 3ddd5d4dff38..9b4ca660b648 100644
--- a/dev-util/makepp/Manifest
+++ b/dev-util/makepp/Manifest
@@ -1,2 +1 @@
-DIST makepp-1.18.tar.gz 236990 BLAKE2B 4f2c894a706fd188eeeae4422ac828cd99cccb2e8f6b7280a2be55363b99f4fff011932f3dfd550062e932f5c90ddc7f41fd56cb5e765c694b7296ac7f7beb1c SHA512 e6d4fe2d8136bbbbec00401761bf5a4bf5ff15357e75080b942188a613b8156c67eac63f46ce89f1e521997ca620f22924dd0b9055dcb66e30801142dab4e0a9
-DIST makepp-2.0.99.1.txz 532784 BLAKE2B e69495f0ffece81e7b15b668eea8bf4f9a26a36332bd1644594d697dd2301bea4bb2340fcd2805a33c44824113149fc617db610e6624900ec9d0d77054658d8c SHA512 457d64a2e9d2860dc2f7ad1bd4ef7df9fcd1563878dcd7b63e6f1d3fd6c03cdb89aab68faa018b3ef6b3009733a365fadbb49ad6c8a03ffe6eafcf867b765213
+DIST makepp-2.0.99.2.txz 528968 BLAKE2B e39c5fa515a1579ef5a568385550e8baf9176eac4a1871cdb7971ca8d3f92bfda73e5f27f4cf00c148a2c5c9622dd8253ebba0f555c6d46ce8c3581678bf8e68 SHA512 5aa8d255e545705802fec6ca304b2c672dfb9c59f7a064a5e9c4ef98f52d7dd5628023fe2a2449126ac1f9cc6ba7bac98233e3e4f07dd8a0559fd8aea7fd24a4
diff --git a/dev-util/makepp/files/makepp-1.18-install.patch b/dev-util/makepp/files/makepp-1.18-install.patch
deleted file mode 100644
index 7d90e2166223..000000000000
--- a/dev-util/makepp/files/makepp-1.18-install.patch
+++ /dev/null
@@ -1,69 +0,0 @@
---- install.pl.orig 2003-02-18 13:15:15.000000000 -0800
-+++ install.pl 2003-02-18 13:49:10.000000000 -0800
-@@ -31,9 +31,24 @@
- #
- # Now figure out where everything goes:
- #
--$prefix = "/usr/local";
-+$prefix = shift(@ARGV) ||
-+ read_with_prompt( "
-+You can specify a prefix directory that will simplify defaults for
-+further questions.
-+
-+What should be the prefix directory [$prefix]? ") ||
-+ "/usr/local";
-+
-+$inst_prefix = shift(@ARGV) ||
-+ read_with_prompt( "
-+You can specify an install prefix that is prefixed to the runtime
-+prefix for the install phase only. This is useful when installing
-+into staging directories for packaging systems.
-
--$bindir = shift(@_) ||
-+What should the install prefix be []? ") ||
-+ "";
-+
-+$bindir = shift(@ARGV) ||
- read_with_prompt("
- Makepp needs to know where you want to install it and its data files.
- makepp is written in perl, but there is no particular reason to install
-@@ -43,10 +58,7 @@
- Where should the makepp executable be installed [$prefix/bin]? ") ||
- "$prefix/bin";
-
--$bindir =~ m@(.*)/bin@ and $prefix = $1;
-- # See if a prefix was specified.
--
--$datadir = shift @_ || read_with_prompt("
-+$datadir = shift @ARGV || read_with_prompt("
- Makepp has a number of library files that it needs to install somewhere. Some
- of these are perl modules, but they can't be used by other perl programs, so
- there's no point in installing them in the perl modules hierarchy; they are
-@@ -55,14 +67,24 @@
- Where should the library files be installed [$prefix/share/makepp]? ") ||
- "$prefix/share/makepp";
-
--$htmldir = shift @_ || read_with_prompt("
-+$htmldir = shift @ARGV || read_with_prompt("
- Where should the HTML documentation be installed?
- Enter \"none\" if you do not want any documentation installed.
- HTML documentation directory [$prefix/share/makepp/html]: ") ||
- "$prefix/share/makepp/html";
-
--substitute_file("makepp", $bindir, 0755);
--substitute_file("recursive_makepp", $datadir, 0644);
-+substitute_file("makepp", "$inst_prefix/$bindir", 0755);
-+substitute_file("recursive_makepp", "$inst_prefix/$datadir", 0644);
-+
-+if( $inst_prefix ) {
-+ $bindir = join( '/', $inst_prefix, $bindir );
-+ $datadir = join( '/', $inst_prefix, $datadir );
-+ $htmldir = join( '/', $inst_prefix, $htmldir );
-+}
-+
-+print STDERR "bindir now $bindir\n";
-+print STDERR "datadir now $datadir\n";
-+print STDERR "htmldir now $htmldir\n";
-
- make_dir("$datadir/Signature");
- foreach $module (qw(FileInfo FileInfo_makepp MakeEvent Glob Makefile Makesubs Rule
diff --git a/dev-util/makepp/makepp-1.18.ebuild b/dev-util/makepp/makepp-1.18.ebuild
deleted file mode 100644
index a5cef1c94211..000000000000
--- a/dev-util/makepp/makepp-1.18.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils
-
-DESCRIPTION="GNU make replacement"
-HOMEPAGE="http://makepp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha ~ppc ~sparc ~x86"
-IUSE=""
-DEPEND=">=dev-lang/perl-5.6.0"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-install.patch
- # There is a sandbox violation in this test.
- # In future versions, this ebuild should try to find
- # a better way of avoiding this, but the current version
- # appears to have garbage NUL characters all over the test files,
- # making them complicated to edit.
- # Robert Coie <rac@gentoo.org> 2002.02.18
- rm "${S}"/makepp_tests/include.test
-}
-
-src_compile() {
- make test || die
-}
-
-src_install() {
- perl install.pl /usr "${D}" /usr/bin /usr/share/makepp /usr/share/doc/makepp
-}
diff --git a/dev-util/makepp/makepp-2.0.99.1.ebuild b/dev-util/makepp/makepp-2.0.99.2.ebuild
index 1e24eea8bbaf..7982a929c505 100644
--- a/dev-util/makepp/makepp-2.0.99.1.ebuild
+++ b/dev-util/makepp/makepp-2.0.99.2.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
MY_PV=${PV/_}
MY_P="${PN}-${MY_PV}"
DESCRIPTION="GNU make replacement"
HOMEPAGE="http://makepp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/2.1/${MY_P}.txz"
+SRC_URI="https://downloads.sourceforge.net/${PN}/2.1/${MY_P}.txz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha ~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos"
IUSE=""
DEPEND="dev-lang/perl:="
@@ -21,6 +21,7 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
# default "all" rule is to run tests :x
sed -i '/^all:/s:test::' config.pl || die
+ sed -i 's/^ my $gzip =.*/ my $gzip = "";/' install.pl || die
default
}
@@ -38,5 +39,5 @@ src_configure() {
src_test() {
# work around https://bugzilla.samba.org/show_bug.cgi?id=8728
export CCACHE_UNIFY=1
- ROOT= default
+ default
}
diff --git a/dev-util/makepp/metadata.xml b/dev-util/makepp/metadata.xml
index dabb537bfa74..52bd68139f73 100644
--- a/dev-util/makepp/metadata.xml
+++ b/dev-util/makepp/metadata.xml
@@ -1,10 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>base-system@gentoo.org</email>
- <name>Gentoo Base System</name>
- </maintainer>
+ <!-- maintainer-needed -->
<upstream>
<remote-id type="sourceforge">makepp</remote-id>
</upstream>