summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mdds/mdds-0.10.3.ebuild')
-rw-r--r--dev-util/mdds/mdds-0.10.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/mdds/mdds-0.10.3.ebuild b/dev-util/mdds/mdds-0.10.3.ebuild
new file mode 100644
index 000000000000..cdccda48b71f
--- /dev/null
+++ b/dev-util/mdds/mdds-0.10.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="http://code.google.com/p/multidimalgorithm/"
+SRC_URI="http://kohei.us/files/${PN}/src/${P/-/_}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="<dev-libs/boost-1.57.0"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/-/_}
+
+src_configure() {
+ econf \
+ --with-hash-container=boost \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() { :; }
+
+src_test() {
+ tc-export CXX
+ default
+}