summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mdds/mdds-9999.ebuild')
-rw-r--r--dev-util/mdds/mdds-9999.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/dev-util/mdds/mdds-9999.ebuild b/dev-util/mdds/mdds-9999.ebuild
index 9185efd612ad..420358f97a95 100644
--- a/dev-util/mdds/mdds-9999.ebuild
+++ b/dev-util/mdds/mdds-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,7 +8,7 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
else
SRC_URI="https://kohei.us/files/${PN}/src/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
inherit autotools toolchain-funcs
@@ -16,19 +16,19 @@ DESCRIPTION="Collection of multi-dimensional data structure and indexing algorit
HOMEPAGE="https://gitlab.com/mdds/mdds"
LICENSE="MIT"
-SLOT="1/2.0" # Check API version on version bumps!
-IUSE="doc openmp valgrind test"
+SLOT="1/3.0" # Check API version on version bumps!
+IUSE="doc openmp test"
RESTRICT="!test? ( test )"
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
BDEPEND="
doc? (
- app-doc/doxygen
+ app-text/doxygen
dev-python/sphinx
)
- valgrind? ( dev-util/valgrind )
+ test? ( dev-util/dejagnu )
"
-DEPEND="dev-libs/boost:="
-RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}/${PN}-1.5.0-buildsystem.patch" )
@@ -49,7 +49,6 @@ src_configure() {
local myeconfargs=(
$(use_enable doc docs)
$(use_enable openmp)
- $(use_enable valgrind memory_tests)
)
econf "${myeconfargs[@]}"
}