summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/opencl-headers/opencl-headers-2022.05.18-r1.ebuild')
-rw-r--r--dev-util/opencl-headers/opencl-headers-2022.05.18-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/opencl-headers/opencl-headers-2022.05.18-r1.ebuild b/dev-util/opencl-headers/opencl-headers-2022.05.18-r1.ebuild
new file mode 100644
index 000000000000..245fefd3e4c0
--- /dev/null
+++ b/dev-util/opencl-headers/opencl-headers-2022.05.18-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PN="OpenCL-Headers"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Unified C language headers for the OpenCL API"
+HOMEPAGE="https://github.com/KhronosGroup/OpenCL-Headers"
+SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}