summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/packer/packer-1.7.10.ebuild')
-rw-r--r--dev-util/packer/packer-1.7.10.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-util/packer/packer-1.7.10.ebuild b/dev-util/packer/packer-1.7.10.ebuild
deleted file mode 100644
index 2805c0f9c87d..000000000000
--- a/dev-util/packer/packer-1.7.10.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit go-module
-
-go-module_set_globals
-
-DESCRIPTION="A tool to create identical machine images for multiple platforms"
-HOMEPAGE="https://www.packer.io"
-SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://gentoofiles.s3.eu-central-1.amazonaws.com/packer-1.7.10-deps.tar.xz"
-
-LICENSE="Apache-2.0 BSD-2 BSD-4 MIT MPL-2.0 unicode"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv"
-
-DOCS=( {README,CHANGELOG}.md )
-
-RESTRICT+=" test"
-
-src_compile() {
- ego build \
- -mod=readonly \
- -ldflags "${go_ldflags}" \
- -work -o "bin/${PN}" ./ || die
-}
-
-src_install() {
- dobin bin/packer
-
- einstalldocs
-
- insinto /usr/share/zsh/site-functions
- doins contrib/zsh-completion/_packer
-}