summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rebar/rebar-2.4.0.ebuild')
-rw-r--r--dev-util/rebar/rebar-2.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/rebar/rebar-2.4.0.ebuild b/dev-util/rebar/rebar-2.4.0.ebuild
new file mode 100644
index 000000000000..9cd5c44cc02d
--- /dev/null
+++ b/dev-util/rebar/rebar-2.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="http://github.com/rebar/rebar"
+SRC_URI="http://github.com/rebar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/erlang"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ emake xref
+}
+
+src_install() {
+ dobin rebar
+ dodoc rebar.config.sample THANKS
+ dobashcomp priv/shell-completion/bash/${PN}
+}