summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/strace/strace-5.4.ebuild')
-rw-r--r--dev-util/strace/strace-5.4.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-util/strace/strace-5.4.ebuild b/dev-util/strace/strace-5.4.ebuild
index db378889c0d5..31a56378b3f8 100644
--- a/dev-util/strace/strace-5.4.ebuild
+++ b/dev-util/strace/strace-5.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs
+inherit flag-o-matic toolchain-funcs autotools
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/strace/strace.git"
@@ -37,9 +37,15 @@ RDEPEND="
perl? ( dev-lang/perl )
"
+PATCHES=( "${FILESDIR}"/${P}-fix-LTO-CFLAGS-handling.patch )
+
src_prepare() {
default
+ # Needed for applied patch (#701516). Remove with next version.
+ # Don't forget about autotools inherit.
+ eautoreconf
+
if [[ ! -e configure ]] ; then
# git generation
sed /autoreconf/d -i bootstrap || die