summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/strace/strace-9999.ebuild')
-rw-r--r--dev-util/strace/strace-9999.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-util/strace/strace-9999.ebuild b/dev-util/strace/strace-9999.ebuild
index 8a1e0d6ef4c6..9a701506480b 100644
--- a/dev-util/strace/strace-9999.ebuild
+++ b/dev-util/strace/strace-9999.ebuild
@@ -19,12 +19,15 @@ HOMEPAGE="http://sourceforge.net/projects/strace/"
LICENSE="BSD"
SLOT="0"
-IUSE="aio perl static"
+IUSE="aio perl static unwind"
+LIB_DEPEND="unwind? ( sys-libs/libunwind[static-libs(+)] )"
# strace only uses the header from libaio to decode structs
-DEPEND="aio? ( >=dev-libs/libaio-0.3.106 )
+DEPEND="static? ( ${LIB_DEPEND} )
+ aio? ( >=dev-libs/libaio-0.3.106 )
sys-kernel/linux-headers"
-RDEPEND="perl? ( dev-lang/perl )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ perl? ( dev-lang/perl )"
src_prepare() {
if epatch_user || [[ ! -e configure ]] ; then
@@ -44,6 +47,10 @@ src_prepare() {
sed -i '1iexit 77' tests*/strace-k.test || die
}
+src_configure() {
+ econf $(use_with unwind libunwind)
+}
+
src_install() {
default
use perl || rm "${ED}"/usr/bin/strace-graph