summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/trace-cmd/files/trace-cmd-2.5.1-makefile.patch')
-rw-r--r--dev-util/trace-cmd/files/trace-cmd-2.5.1-makefile.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/trace-cmd/files/trace-cmd-2.5.1-makefile.patch b/dev-util/trace-cmd/files/trace-cmd-2.5.1-makefile.patch
new file mode 100644
index 000000000000..ec9fb1774a3a
--- /dev/null
+++ b/dev-util/trace-cmd/files/trace-cmd-2.5.1-makefile.patch
@@ -0,0 +1,34 @@
+diff --git a/Makefile b/Makefile
+index 186e245..9127f23 100644
+--- a/Makefile
++++ b/Makefile
+@@ -58,7 +58,7 @@ plugin_dir = $(HOME)/.trace-cmd/plugins
+ python_dir = $(HOME)/.trace-cmd/python
+ else
+ plugin_dir = $(prefix)/$(libdir)/trace-cmd/plugins
+-python_dir = $(prefix)/$(libdir)/trace-cmd/python
++python_dir ?= $(prefix)/$(libdir)/trace-cmd/python
+ PLUGIN_DIR = -DPLUGIN_DIR="$(plugin_dir)"
+ PYTHON_DIR = -DPYTHON_DIR="$(python_dir)"
+ PLUGIN_DIR_SQ = '$(subst ','\'',$(PLUGIN_DIR))'
+@@ -98,8 +98,11 @@ endif # NO_PYTHON
+ test-build = $(if $(shell sh -c 'echo "$(1)" | \
+ $(CC) -o /dev/null -c -x c - > /dev/null 2>&1 && echo y'), $2)
+
++ifndef NO_UDIS86
+ # have udis86 disassembler library?
+-udis86-flags := $(call test-build,\#include <udis86.h>,-DHAVE_UDIS86 -ludis86)
++udis86-flags := -DHAVE_UDIS86
++udis86-ldflags := -ludis86
++endif # NO_UDIS86
+
+ define BLK_TC_FLUSH_SOURCE
+ #include <linux/blktrace_api.h>
+@@ -242,6 +245,7 @@ endif
+ # Append required CFLAGS
+ override CFLAGS += $(CONFIG_FLAGS) $(INCLUDES) $(PLUGIN_DIR_SQ)
+ override CFLAGS += $(udis86-flags) $(blk-flags)
++override LDFLAGS += $(udis86-ldflags)
+
+ ifeq ($(VERBOSE),1)
+ Q =