summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/tup/tup-9999.ebuild')
-rw-r--r--dev-util/tup/tup-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-util/tup/tup-9999.ebuild b/dev-util/tup/tup-9999.ebuild
index 104dd83a9dbd..e248bb29dc6c 100644
--- a/dev-util/tup/tup-9999.ebuild
+++ b/dev-util/tup/tup-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit linux-info toolchain-funcs
DESCRIPTION="A file-based build system"
HOMEPAGE="http://gittup.org/tup"
@@ -30,6 +30,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+CONFIG_CHECK="~FUSE_FS ~NAMESPACES"
+WARNING_FUSE_FS="CONFIG_FUSE_FS is required for tup to work"
+WARNING_NAMESPACES="CONFIG_NAMESPACES is required for tup to work as intended (workaround: set TUP_NO_NAMESPACING env var when running tup)"
+
src_prepare() {
# Use our toolchain
sed -i Tuprules.tup \