summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/vulkan-tools')
-rw-r--r--dev-util/vulkan-tools/Manifest3
-rw-r--r--dev-util/vulkan-tools/vulkan-tools-1.3.280.0.ebuild (renamed from dev-util/vulkan-tools/vulkan-tools-1.3.216.ebuild)48
-rw-r--r--dev-util/vulkan-tools/vulkan-tools-1.3.283.0.ebuild85
-rw-r--r--dev-util/vulkan-tools/vulkan-tools-9999.ebuild48
4 files changed, 137 insertions, 47 deletions
diff --git a/dev-util/vulkan-tools/Manifest b/dev-util/vulkan-tools/Manifest
index 7a6b8b318367..936ed2304249 100644
--- a/dev-util/vulkan-tools/Manifest
+++ b/dev-util/vulkan-tools/Manifest
@@ -1 +1,2 @@
-DIST vulkan-tools-1.3.216.tar.gz 866091 BLAKE2B 750b7d26de64844162f13bb5f2c82b134c0996e2bf23883b381fc05bb8eb26c19ef3a8dc4da63543096473845952115a8e3213ee3972baa9b01104adaa09ed82 SHA512 57d152072ecad744256397e357d756f82457929a026a29127a079ea7b3b805b99ece1e0eddfecb215882a8de18cf9ab3c32c4c90126e261bc582ad05ae6173e2
+DIST vulkan-tools-1.3.280.0.tar.gz 758884 BLAKE2B 99d9157a3e701d6f143f6f893c85c0f1d9df13f0b8ca75cc8b8985e92272f4621a03094e6bc5c0b24eca9036b622a774acb9f539c30196ab2c2c1505870e72a2 SHA512 d28dd0a83e993058f58ba83c148a3104c1bbe4e731b81bfc934a989dfcdf3cc1b22383bcaee2a34545ddb9b053e00bea3da463d48fa10727a18ee7e34641d1cb
+DIST vulkan-tools-1.3.283.0.tar.gz 753022 BLAKE2B dbd636186d7674c954f8237e7943f3cb89d172f870d0771d84d5615caec3013f284700a2c07b33a74f12e310e9c1bdd50ef8e93f459b73ace318fb68f33c7503 SHA512 714e2ff89cbd4171dae5c5825b71210572571965ba86c68f38c1ea62c9ff512e1c0dc278c02786d45d3a775985b40e8c1bd47ab37d22668105fd2e09d7524656
diff --git a/dev-util/vulkan-tools/vulkan-tools-1.3.216.ebuild b/dev-util/vulkan-tools/vulkan-tools-1.3.280.0.ebuild
index 2ac82693de65..ce7f09c30592 100644
--- a/dev-util/vulkan-tools/vulkan-tools-1.3.216.ebuild
+++ b/dev-util/vulkan-tools/vulkan-tools-1.3.280.0.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MY_PN=Vulkan-Tools
-CMAKE_ECLASS="cmake"
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake-multilib python-any-r1
if [[ ${PV} == *9999* ]]; then
@@ -13,9 +12,9 @@ if [[ ${PV} == *9999* ]]; then
EGIT_SUBMODULES=()
inherit git-r3
else
- SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/sdk-${PV}.0.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/vulkan-sdk-${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv"
- S="${WORKDIR}"/${MY_PN}-sdk-${PV}.0
+ S="${WORKDIR}"/${MY_PN}-vulkan-sdk-${PV}
fi
DESCRIPTION="Official Vulkan Tools and Utilities for Windows, Linux, Android, and MacOS"
@@ -23,25 +22,23 @@ HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Tools"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="cube wayland +X"
-
-# Cube demo only supports one window system at a time
-REQUIRED_USE="cube? ( ^^ ( X wayland ) )"
+IUSE="cube wayland X"
BDEPEND="${PYTHON_DEPS}
- >=dev-util/cmake-3.10.2
cube? ( ~dev-util/glslang-${PV}:=[${MULTILIB_USEDEP}] )
"
RDEPEND="
- ~media-libs/vulkan-loader-${PV}:=[${MULTILIB_USEDEP},wayland?,X?]
- wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
+ ~dev-util/volk-${PV}:=[${MULTILIB_USEDEP}]
+ ~media-libs/vulkan-loader-${PV}[${MULTILIB_USEDEP},wayland?,X?]
+ wayland? ( dev-libs/wayland[${MULTILIB_USEDEP}] )
X? (
- x11-libs/libX11:=[${MULTILIB_USEDEP}]
- x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:=[${MULTILIB_USEDEP}]
)
"
DEPEND="${RDEPEND}
~dev-util/vulkan-headers-${PV}
+ X? ( x11-libs/libXrandr[${MULTILIB_USEDEP}] )
"
pkg_setup() {
@@ -53,6 +50,9 @@ pkg_setup() {
/usr/bin/vkcube
/usr/bin/vkcubepp
)
+ use cube && use wayland && MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/vkcube-wayland
+ )
python-any-r1_pkg_setup
}
@@ -64,20 +64,22 @@ multilib_src_configure() {
-DCMAKE_SKIP_RPATH=ON
-DBUILD_VULKANINFO=ON
-DBUILD_CUBE=$(usex cube)
+ -DBUILD_WERROR=OFF
-DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
-DBUILD_WSI_XCB_SUPPORT=$(usex X)
-DBUILD_WSI_XLIB_SUPPORT=$(usex X)
-DVULKAN_HEADERS_INSTALL_DIR="${ESYSROOT}/usr"
)
- use cube && mycmakeargs+=(
- -DGLSLANG_INSTALL_DIR="${ESYSROOT}/usr"
- -DCUBE_WSI_SELECTION=$(usex X XCB WAYLAND)
- )
+ if use cube; then
+ if use X; then
+ mycmakeargs+=(-DCUBE_WSI_SELECTION=XCB)
+ elif use wayland; then
+ mycmakeargs+=(-DCUBE_WSI_SELECTION=WAYLAND)
+ else
+ mycmakeargs+=(-DCUBE_WSI_SELECTION=DISPLAY)
+ fi
+ fi
cmake_src_configure
}
-
-multilib_src_install() {
- cmake_src_install
-}
diff --git a/dev-util/vulkan-tools/vulkan-tools-1.3.283.0.ebuild b/dev-util/vulkan-tools/vulkan-tools-1.3.283.0.ebuild
new file mode 100644
index 000000000000..1c19288ef980
--- /dev/null
+++ b/dev-util/vulkan-tools/vulkan-tools-1.3.283.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=Vulkan-Tools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit cmake-multilib python-any-r1
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
+ EGIT_SUBMODULES=()
+ inherit git-r3
+else
+ SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/vulkan-sdk-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv"
+ S="${WORKDIR}"/${MY_PN}-vulkan-sdk-${PV}
+fi
+
+DESCRIPTION="Official Vulkan Tools and Utilities for Windows, Linux, Android, and MacOS"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="cube wayland X"
+
+BDEPEND="${PYTHON_DEPS}
+ cube? ( ~dev-util/glslang-${PV}:=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ ~dev-util/volk-${PV}:=[${MULTILIB_USEDEP}]
+ ~media-libs/vulkan-loader-${PV}[${MULTILIB_USEDEP},wayland?,X?]
+ wayland? ( dev-libs/wayland[${MULTILIB_USEDEP}] )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:=[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ ~dev-util/vulkan-headers-${PV}
+ X? ( x11-libs/libXrandr[${MULTILIB_USEDEP}] )
+"
+
+pkg_setup() {
+ MULTILIB_CHOST_TOOLS=(
+ /usr/bin/vulkaninfo
+ )
+
+ use cube && MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/vkcube
+ /usr/bin/vkcubepp
+ )
+ use cube && use wayland && MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/vkcube-wayland
+ )
+
+ python-any-r1_pkg_setup
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_C_FLAGS="${CFLAGS} -DNDEBUG"
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS} -DNDEBUG"
+ -DCMAKE_SKIP_RPATH=ON
+ -DBUILD_VULKANINFO=ON
+ -DBUILD_CUBE=$(usex cube)
+ -DBUILD_WERROR=OFF
+ -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
+ -DBUILD_WSI_XCB_SUPPORT=$(usex X)
+ -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
+ -DVULKAN_HEADERS_INSTALL_DIR="${ESYSROOT}/usr"
+ )
+
+ if use cube; then
+ if use X; then
+ mycmakeargs+=(-DCUBE_WSI_SELECTION=XCB)
+ elif use wayland; then
+ mycmakeargs+=(-DCUBE_WSI_SELECTION=WAYLAND)
+ else
+ mycmakeargs+=(-DCUBE_WSI_SELECTION=DISPLAY)
+ fi
+ fi
+
+ cmake_src_configure
+}
diff --git a/dev-util/vulkan-tools/vulkan-tools-9999.ebuild b/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
index c3a3fd4a0e09..1c19288ef980 100644
--- a/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
+++ b/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MY_PN=Vulkan-Tools
-CMAKE_ECLASS="cmake"
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit cmake-multilib python-any-r1
if [[ ${PV} == *9999* ]]; then
@@ -13,9 +12,9 @@ if [[ ${PV} == *9999* ]]; then
EGIT_SUBMODULES=()
inherit git-r3
else
- SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/sdk-${PV}.0.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/vulkan-sdk-${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv"
- S="${WORKDIR}"/${MY_PN}-sdk-${PV}.0
+ S="${WORKDIR}"/${MY_PN}-vulkan-sdk-${PV}
fi
DESCRIPTION="Official Vulkan Tools and Utilities for Windows, Linux, Android, and MacOS"
@@ -23,25 +22,23 @@ HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Tools"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="cube wayland +X"
-
-# Cube demo only supports one window system at a time
-REQUIRED_USE="cube? ( ^^ ( X wayland ) )"
+IUSE="cube wayland X"
BDEPEND="${PYTHON_DEPS}
- >=dev-util/cmake-3.10.2
cube? ( ~dev-util/glslang-${PV}:=[${MULTILIB_USEDEP}] )
"
RDEPEND="
- ~media-libs/vulkan-loader-${PV}:=[${MULTILIB_USEDEP},wayland?,X?]
- wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
+ ~dev-util/volk-${PV}:=[${MULTILIB_USEDEP}]
+ ~media-libs/vulkan-loader-${PV}[${MULTILIB_USEDEP},wayland?,X?]
+ wayland? ( dev-libs/wayland[${MULTILIB_USEDEP}] )
X? (
- x11-libs/libX11:=[${MULTILIB_USEDEP}]
- x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:=[${MULTILIB_USEDEP}]
)
"
DEPEND="${RDEPEND}
~dev-util/vulkan-headers-${PV}
+ X? ( x11-libs/libXrandr[${MULTILIB_USEDEP}] )
"
pkg_setup() {
@@ -53,6 +50,9 @@ pkg_setup() {
/usr/bin/vkcube
/usr/bin/vkcubepp
)
+ use cube && use wayland && MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/vkcube-wayland
+ )
python-any-r1_pkg_setup
}
@@ -64,20 +64,22 @@ multilib_src_configure() {
-DCMAKE_SKIP_RPATH=ON
-DBUILD_VULKANINFO=ON
-DBUILD_CUBE=$(usex cube)
+ -DBUILD_WERROR=OFF
-DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
-DBUILD_WSI_XCB_SUPPORT=$(usex X)
-DBUILD_WSI_XLIB_SUPPORT=$(usex X)
-DVULKAN_HEADERS_INSTALL_DIR="${ESYSROOT}/usr"
)
- use cube && mycmakeargs+=(
- -DGLSLANG_INSTALL_DIR="${ESYSROOT}/usr"
- -DCUBE_WSI_SELECTION=$(usex X XCB WAYLAND)
- )
+ if use cube; then
+ if use X; then
+ mycmakeargs+=(-DCUBE_WSI_SELECTION=XCB)
+ elif use wayland; then
+ mycmakeargs+=(-DCUBE_WSI_SELECTION=WAYLAND)
+ else
+ mycmakeargs+=(-DCUBE_WSI_SELECTION=DISPLAY)
+ fi
+ fi
cmake_src_configure
}
-
-multilib_src_install() {
- cmake_src_install
-}