summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/gitinspector')
-rw-r--r--dev-vcs/gitinspector/Manifest2
-rw-r--r--dev-vcs/gitinspector/gitinspector-0.3.1.ebuild22
-rw-r--r--dev-vcs/gitinspector/gitinspector-0.3.2.ebuild27
-rw-r--r--dev-vcs/gitinspector/metadata.xml7
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-vcs/gitinspector/Manifest b/dev-vcs/gitinspector/Manifest
new file mode 100644
index 000000000000..44d4ed0eea3b
--- /dev/null
+++ b/dev-vcs/gitinspector/Manifest
@@ -0,0 +1,2 @@
+DIST gitinspector_0.3.1.zip 235252 SHA256 0081f142e507ff49cb4f5ca1119eb11f66655af1bfb327aa4670c31245e608d0 SHA512 f7ba3b4ebededc8ff80e440de26c3e858c4e413dd02c516aa442c05ef27875e0eb78e6430018717890aa390ef5a1011a33da28e0748a07c59830df6ffeb35c63 WHIRLPOOL 95d80614a5f2c38c9c01e5958f778eb72935f81e3aa44bd831332047f633625587f75f598112c005b0709c7b209a732286c1da578c07c74c22066c65d31d2964
+DIST gitinspector_0.3.2.zip 254971 SHA256 3778e60514f5067f8f2628da5cacbce12db99af6517fcf448afb2964bce963a7 SHA512 2a6a48f2b1b7f7add11be034addca727845aa50860286ea50a4fff0a84b14f840c2776dd679b8c2f11d528b93712c7384aa318ffb08bb01f69faf436b6bcaa5a WHIRLPOOL df6f808ea3bd1b04bcf99416d2f5abb3b6241c6212d22676058ed73e9406c39a517881c01c3f73f26e880b648de131422134a1112f7dfd81ebc30837eb0166b7
diff --git a/dev-vcs/gitinspector/gitinspector-0.3.1.ebuild b/dev-vcs/gitinspector/gitinspector-0.3.1.ebuild
new file mode 100644
index 000000000000..9b206727d139
--- /dev/null
+++ b/dev-vcs/gitinspector/gitinspector-0.3.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Statistical analysis tool for git repositories"
+HOMEPAGE="https://code.google.com/p/gitinspector/"
+SRC_URI="https://${PN}.googlecode.com/files/${PN}_${PV}.zip"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-vcs/git"
+DEPEND="
+ test? ( ${RDEPEND} )"
diff --git a/dev-vcs/gitinspector/gitinspector-0.3.2.ebuild b/dev-vcs/gitinspector/gitinspector-0.3.2.ebuild
new file mode 100644
index 000000000000..b9c7d97dee95
--- /dev/null
+++ b/dev-vcs/gitinspector/gitinspector-0.3.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Statistical analysis tool for git repositories"
+HOMEPAGE="https://code.google.com/p/gitinspector/"
+SRC_URI="https://${PN}.googlecode.com/files/${PN}_${PV}.zip"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-vcs/git"
+DEPEND="
+ test? ( ${RDEPEND} )"
+
+python_prepare_all() {
+ [[ ${LC_ALL} == "C" ]] && export LC_ALL="en_US.utf8"
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-vcs/gitinspector/metadata.xml b/dev-vcs/gitinspector/metadata.xml
new file mode 100644
index 000000000000..4a00a64b40ae
--- /dev/null
+++ b/dev-vcs/gitinspector/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>