summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/mr')
-rw-r--r--dev-vcs/mr/Manifest2
-rw-r--r--dev-vcs/mr/metadata.xml33
-rw-r--r--dev-vcs/mr/mr-1.20140831.1.ebuild32
-rw-r--r--dev-vcs/mr/mr-1.20141024.ebuild32
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-vcs/mr/Manifest b/dev-vcs/mr/Manifest
new file mode 100644
index 000000000000..696ec2d58abd
--- /dev/null
+++ b/dev-vcs/mr/Manifest
@@ -0,0 +1,2 @@
+DIST mr-1.20140831.1.tar.gz 44706 SHA256 efb864848d3c557d913138a52e3d5a4736edcccd9f9b46bb65931060cf8548f0 SHA512 f8004c37200bf0f227371d2cb747f38c1bf37d1ff270c299b1a97ee92b22a2be039da3c8e9b31b4402adb8ee985a16764115debedad027c5b0f830ceb3a39216 WHIRLPOOL d2eff39628324c3be7996a715ff487e8cb37313eecaed4dcaa25bc320c5d96ba32cc578a85dab241b53556b297ba29def3cd9ea2b3b5a7afe5e2dac57cfd544b
+DIST mr-1.20141024.tar.gz 45032 SHA256 7b68183476867d15d6f111fc9678335b94824dcfa09f07c761a72d64cdf5ad4a SHA512 d39428bc9858a3d9649ff841fa688a5cb92632bf957af9101c7f7e709d2821dbc38a2ab5400d9fe31208159873156cc6d740538b5567e758c35afb01744000d6 WHIRLPOOL a806e3543b1fc4864b2581883a348cc1441a75fb8ebd4fe6ab393f8180b820e0b389c0b40123798b8257a1641409747981227b6616368eafda4f3d56e9ba39a5
diff --git a/dev-vcs/mr/metadata.xml b/dev-vcs/mr/metadata.xml
new file mode 100644
index 000000000000..9e6151942610
--- /dev/null
+++ b/dev-vcs/mr/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <longdescription lang="en">
+ The mr(1) command can checkout, update, or perform other actions on a
+ set of repositories as if they were one combined respository. It
+ supports any combination of git, svn, mercurial, bzr, darcs, cvs, vcsh,
+ fossil, and veracity repositories, and support for other version control
+ systems can easily be added. (There are extensions adding support for unison
+ and git-svn.)
+
+ It is extremely configurable via simple shell scripting. Some examples
+ of things it can do include:
+
+ * Update a repository no more frequently than once every twelve hours.
+ * Run an arbitrary command before committing to a repository.
+ * When updating a git repository, pull from two different upstreams
+ and merge the two together.
+ * Run several repository updates in parallel, greatly speeding up
+ the update process.
+ * Remember actions that failed due to a laptop being offline,
+ so they can be retried when it comes back online.
+
+ This package also includes the webcheckout command.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">joeyh/myrepos</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-vcs/mr/mr-1.20140831.1.ebuild b/dev-vcs/mr/mr-1.20140831.1.ebuild
new file mode 100644
index 000000000000..d051afa7157a
--- /dev/null
+++ b/dev-vcs/mr/mr-1.20140831.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="myrepos-${PV}"
+
+DESCRIPTION="Multiple Repository management tool"
+HOMEPAGE="https://github.com/joeyh/myrepos"
+SRC_URI="https://github.com/joeyh/myrepos/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/libwww-perl
+ dev-perl/HTML-Parser
+"
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dobin mr webcheckout
+ doman mr.1 webcheckout.1
+ dodoc README debian/changelog \
+ mrconfig mrconfig.complex
+ insinto /usr/share/${PN}
+ doins lib/*
+}
diff --git a/dev-vcs/mr/mr-1.20141024.ebuild b/dev-vcs/mr/mr-1.20141024.ebuild
new file mode 100644
index 000000000000..c2fb1cc1aaa9
--- /dev/null
+++ b/dev-vcs/mr/mr-1.20141024.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="myrepos-${PV}"
+
+DESCRIPTION="Multiple Repository management tool"
+HOMEPAGE="https://github.com/joeyh/myrepos"
+SRC_URI="https://github.com/joeyh/myrepos/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/libwww-perl
+ dev-perl/HTML-Parser
+"
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dobin mr webcheckout
+ doman mr.1 webcheckout.1
+ dodoc README debian/changelog \
+ mrconfig mrconfig.complex
+ insinto /usr/share/${PN}
+ doins lib/*
+}