summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild')
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild
deleted file mode 100644
index 2be1c12294f1..000000000000
--- a/dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 )
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="Python command line interface to gitlab API"
-HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
-
-LICENSE="LGPL-3"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/testrepository[${PYTHON_USEDEP}]
- dev-python/hacking[${PYTHON_USEDEP}]
- dev-python/httmock[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.3
- dev-python/sphinx_rtd_theme )"
-
-RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc -r *.rst docs
-}