summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/svn2cl/svn2cl-0.12.ebuild')
-rw-r--r--dev-vcs/svn2cl/svn2cl-0.12.ebuild26
1 files changed, 9 insertions, 17 deletions
diff --git a/dev-vcs/svn2cl/svn2cl-0.12.ebuild b/dev-vcs/svn2cl/svn2cl-0.12.ebuild
index 1591242a7069..d788d5b194c9 100644
--- a/dev-vcs/svn2cl/svn2cl-0.12.ebuild
+++ b/dev-vcs/svn2cl/svn2cl-0.12.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
-
-inherit eutils
+EAPI=7
DESCRIPTION="Create a GNU-style ChangeLog from subversion's svn log --xml output"
-HOMEPAGE="http://ch.tudelft.nl/~arthur/svn2cl/"
-SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+HOMEPAGE="https://arthurdejong.org/svn2cl/"
+SRC_URI="https://arthurdejong.org/svn2cl/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -17,20 +15,14 @@ IUSE=""
RDEPEND="dev-libs/libxslt
dev-vcs/subversion"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # the wrapper script looks for the xsl files in the
- # same directory as the script.
- epatch "${FILESDIR}"/0.9-wrapper.patch
-}
+PATCHES=( "${FILESDIR}/0.9-wrapper.patch" )
src_install() {
- newbin svn2cl.sh svn2cl || die "failed to install wrapper script"
+ newbin svn2cl.sh svn2cl
insinto /usr/share/svn2cl
- doins svn2cl.xsl svn2html.xsl || die
- dodoc README NEWS TODO ChangeLog authors.xml svn2html.css || die
- doman svn2cl.1 || die
+ doins svn2cl.xsl svn2html.xsl
+ dodoc README NEWS TODO ChangeLog authors.xml svn2html.css
+ doman svn2cl.1
}
pkg_postinst() {