summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/git-2.14.1.ebuild5
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild5
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild5
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild5
-rw-r--r--dev-vcs/git/git-9999.ebuild5
5 files changed, 15 insertions, 10 deletions
diff --git a/dev-vcs/git/git-2.14.1.ebuild b/dev-vcs/git/git-2.14.1.ebuild
index 50f3a1988c8f..f650073b5ca7 100644
--- a/dev-vcs/git/git-2.14.1.ebuild
+++ b/dev-vcs/git/git-2.14.1.ebuild
@@ -157,7 +157,7 @@ exportmakeopts() {
myopts+=" NO_CURL=YesPlease"
fi
- # broken assumptions, because of broken build system ...
+ # broken assumptions, because of static build system ...
myopts+=" NO_FINK=YesPlease NO_DARWIN_PORTS=YesPlease"
myopts+=" INSTALL=install TAR=tar"
myopts+=" SHELL_PATH=${EPREFIX}/bin/sh"
@@ -219,7 +219,8 @@ exportmakeopts() {
if [[ ${CHOST} == *-solaris* ]]; then
myopts+=" NEEDS_LIBICONV=YesPlease"
myopts+=" HAVE_CLOCK_MONOTONIC=1"
- myopts+=" HAVE_GETDELIM=1"
+ grep -q getdelim "${ROOT}"/usr/include/stdio.h && \
+ myopts+=" HAVE_GETDELIM=1"
fi
has_version '>=app-text/asciidoc-8.0' \
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 1dd3819d0a77..b588ab740808 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -157,7 +157,7 @@ exportmakeopts() {
myopts+=" NO_CURL=YesPlease"
fi
- # broken assumptions, because of broken build system ...
+ # broken assumptions, because of static build system ...
myopts+=" NO_FINK=YesPlease NO_DARWIN_PORTS=YesPlease"
myopts+=" INSTALL=install TAR=tar"
myopts+=" SHELL_PATH=${EPREFIX}/bin/sh"
@@ -219,7 +219,8 @@ exportmakeopts() {
if [[ ${CHOST} == *-solaris* ]]; then
myopts+=" NEEDS_LIBICONV=YesPlease"
myopts+=" HAVE_CLOCK_MONOTONIC=1"
- myopts+=" HAVE_GETDELIM=1"
+ grep -q getdelim "${ROOT}"/usr/include/stdio.h && \
+ myopts+=" HAVE_GETDELIM=1"
fi
has_version '>=app-text/asciidoc-8.0' \
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 17621717d20c..01272659efb9 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -157,7 +157,7 @@ exportmakeopts() {
myopts+=" NO_CURL=YesPlease"
fi
- # broken assumptions, because of broken build system ...
+ # broken assumptions, because of static build system ...
myopts+=" NO_FINK=YesPlease NO_DARWIN_PORTS=YesPlease"
myopts+=" INSTALL=install TAR=tar"
myopts+=" SHELL_PATH=${EPREFIX}/bin/sh"
@@ -219,7 +219,8 @@ exportmakeopts() {
if [[ ${CHOST} == *-solaris* ]]; then
myopts+=" NEEDS_LIBICONV=YesPlease"
myopts+=" HAVE_CLOCK_MONOTONIC=1"
- myopts+=" HAVE_GETDELIM=1"
+ grep -q getdelim "${ROOT}"/usr/include/stdio.h && \
+ myopts+=" HAVE_GETDELIM=1"
fi
has_version '>=app-text/asciidoc-8.0' \
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 1ef3c35807cd..76bcaf24d0d8 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -157,7 +157,7 @@ exportmakeopts() {
myopts+=" NO_CURL=YesPlease"
fi
- # broken assumptions, because of broken build system ...
+ # broken assumptions, because of static build system ...
myopts+=" NO_FINK=YesPlease NO_DARWIN_PORTS=YesPlease"
myopts+=" INSTALL=install TAR=tar"
myopts+=" SHELL_PATH=${EPREFIX}/bin/sh"
@@ -219,7 +219,8 @@ exportmakeopts() {
if [[ ${CHOST} == *-solaris* ]]; then
myopts+=" NEEDS_LIBICONV=YesPlease"
myopts+=" HAVE_CLOCK_MONOTONIC=1"
- myopts+=" HAVE_GETDELIM=1"
+ grep -q getdelim "${ROOT}"/usr/include/stdio.h && \
+ myopts+=" HAVE_GETDELIM=1"
fi
has_version '>=app-text/asciidoc-8.0' \
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 98deedf0d9f6..aa7cf5a5b93d 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -157,7 +157,7 @@ exportmakeopts() {
myopts+=" NO_CURL=YesPlease"
fi
- # broken assumptions, because of broken build system ...
+ # broken assumptions, because of static build system ...
myopts+=" NO_FINK=YesPlease NO_DARWIN_PORTS=YesPlease"
myopts+=" INSTALL=install TAR=tar"
myopts+=" SHELL_PATH=${EPREFIX}/bin/sh"
@@ -219,7 +219,8 @@ exportmakeopts() {
if [[ ${CHOST} == *-solaris* ]]; then
myopts+=" NEEDS_LIBICONV=YesPlease"
myopts+=" HAVE_CLOCK_MONOTONIC=1"
- myopts+=" HAVE_GETDELIM=1"
+ grep -q getdelim "${ROOT}"/usr/include/stdio.h && \
+ myopts+=" HAVE_GETDELIM=1"
fi
has_version '>=app-text/asciidoc-8.0' \