summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/clanbomber')
-rw-r--r--games-action/clanbomber/clanbomber-2.1.1-r1.ebuild1
-rw-r--r--games-action/clanbomber/files/clanbomber-2.1.1-gcc6.patch19
2 files changed, 20 insertions, 0 deletions
diff --git a/games-action/clanbomber/clanbomber-2.1.1-r1.ebuild b/games-action/clanbomber/clanbomber-2.1.1-r1.ebuild
index 7fbbd88aa00a..eee357249b52 100644
--- a/games-action/clanbomber/clanbomber-2.1.1-r1.ebuild
+++ b/games-action/clanbomber/clanbomber-2.1.1-r1.ebuild
@@ -29,6 +29,7 @@ DOCS=( AUTHORS ChangeLog ChangeLog.hg IDEAS NEWS QUOTES README TODO )
PATCHES=(
"${FILESDIR}"/${P}-automake112.patch
"${FILESDIR}"/${P}-boost150.patch
+ "${FILESDIR}"/${P}-gcc6.patch
)
src_prepare() {
diff --git a/games-action/clanbomber/files/clanbomber-2.1.1-gcc6.patch b/games-action/clanbomber/files/clanbomber-2.1.1-gcc6.patch
new file mode 100644
index 000000000000..714e9de85fa2
--- /dev/null
+++ b/games-action/clanbomber/files/clanbomber-2.1.1-gcc6.patch
@@ -0,0 +1,19 @@
+--- a/src/Credits.h
++++ b/src/Credits.h
+@@ -47,7 +47,7 @@
+ int speed;
+ bool stopped;
+ private:
+- static const float yoffset_start = 50;
++ static const float yoffset_start;
+ static const int normal_speed = 40;
+ static const int text_height = 40;
+
+--- a/src/Credits.cpp
++++ b/src/Credits.cpp
+@@ -273,3 +273,5 @@
+ (*draw_list_iter)->show();
+ }
+ }
++
++const float Credits::yoffset_start = 50;