summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/guacamelee')
-rw-r--r--games-action/guacamelee/Manifest1
-rw-r--r--games-action/guacamelee/guacamelee-20231012.ebuild54
-rw-r--r--games-action/guacamelee/metadata.xml8
3 files changed, 63 insertions, 0 deletions
diff --git a/games-action/guacamelee/Manifest b/games-action/guacamelee/Manifest
new file mode 100644
index 000000000000..8a3c1963454e
--- /dev/null
+++ b/games-action/guacamelee/Manifest
@@ -0,0 +1 @@
+DIST Guacamelee_DRMFREE.sh 552784497 BLAKE2B 1f36e1a6b65bcf774d0f4e15b37d8eda3ec91691c7e3c556f73e903559c3215f3611fdbec284259fe7690037cf4ab8e338c1caa7faea80c8ce98d02581b0de4b SHA512 e52c4099e15f20df6512c3c9617cbf29f5ea428c117a0520ce57bacf99b7d33ace6a04c811fd9ced63b7ba11a3a79549b93f83fd18e42ca9a1366aeb4114cd87
diff --git a/games-action/guacamelee/guacamelee-20231012.ebuild b/games-action/guacamelee/guacamelee-20231012.ebuild
new file mode 100644
index 000000000000..a454e11f1411
--- /dev/null
+++ b/games-action/guacamelee/guacamelee-20231012.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker xdg
+
+DESCRIPTION="Metroidvania-style action-platformer set in a magical Mexican-inspired world"
+HOMEPAGE="https://guacamelee.com"
+SRC_URI="Guacamelee_DRMFREE.sh"
+S="${WORKDIR}/data"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ media-libs/libsdl2[abi_x86_32,joystick,opengl,sound,threads(+),video]
+ media-libs/libglvnd[abi_x86_32,X]
+"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+ einfo "This package requires the Guacamelee! Gold Edition file included in"
+ einfo "Humble Indie Bundle 11. If you have it then please move"
+ einfo "${SRC_URI} to your distfiles directory. If you"
+ einfo "missed it then the game is also available to buy from GOG but the"
+ einfo "package will need adapting first. Please contact the Gentoo Games team"
+ einfo "if you bought it from GOG."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${DIR}"
+ newexe x86/game-bin ${PN}
+ dosym "${DIR}"/${PN} /usr/bin/${PN}
+
+ insinto "${DIR}"
+ doins -r noarch/{*.dat*,media/}
+
+ exeinto "${DIR}/lib32"
+ doexe x86/lib32/libfmod*.so
+
+ dodoc noarch/README.linux
+
+ newicon -s 512 noarch/Guacamelee.png ${PN}.png
+ make_desktop_entry ${PN} "Guacamelee"
+}
diff --git a/games-action/guacamelee/metadata.xml b/games-action/guacamelee/metadata.xml
new file mode 100644
index 000000000000..7c730d47817a
--- /dev/null
+++ b/games-action/guacamelee/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>