summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/rafkill')
-rw-r--r--games-action/rafkill/Manifest1
-rw-r--r--games-action/rafkill/files/rafkill-1.2.3-build.patch27
-rw-r--r--games-action/rafkill/files/rafkill-1.2.3-gcc43.patch106
-rw-r--r--games-action/rafkill/files/rafkill-1.2.3-gcc47.patch11
-rw-r--r--games-action/rafkill/files/rafkill-1.2.3-ldflags.patch17
-rw-r--r--games-action/rafkill/metadata.xml8
-rw-r--r--games-action/rafkill/rafkill-1.2.3.ebuild44
7 files changed, 214 insertions, 0 deletions
diff --git a/games-action/rafkill/Manifest b/games-action/rafkill/Manifest
new file mode 100644
index 000000000000..e4f1c6380cfa
--- /dev/null
+++ b/games-action/rafkill/Manifest
@@ -0,0 +1 @@
+DIST rafkill-1.2.3.tar.gz 6221729 SHA256 7d43026b33b63b2b01ea2d0169653749e6f8404b30ba5a2701e797bb16d0a63a SHA512 1ab8ce90f9b823092432519dbafed43db3eb6f9189dda4ced1bbce78b826b37759d0768fffdd2df1c77cbbbf1c3c88db1cc9fe1b59c815d832ebc9aed279d03c WHIRLPOOL 657296a4f843c680672f2262359796086cb9f7c2d9e88ecef591713738edcbf02d8d527902ed2b4366d3de3aea7f11e95e62746ed259bbbeb5e6d427531d4b2c
diff --git a/games-action/rafkill/files/rafkill-1.2.3-build.patch b/games-action/rafkill/files/rafkill-1.2.3-build.patch
new file mode 100644
index 000000000000..3f96be02316f
--- /dev/null
+++ b/games-action/rafkill/files/rafkill-1.2.3-build.patch
@@ -0,0 +1,27 @@
+--- SConstruct
++++ SConstruct
+@@ -8,8 +8,8 @@
+
+ print "Use 'scons -h' for help"
+
+-prefix = '/usr/local/games'
+-bin = '/usr/local/bin'
++prefix = 'data'
++bin = 'src'
+ if sys.platform == 'win32':
+ try:
+ Execute(Mkdir('gen'))
+@@ -46,7 +46,12 @@
+ # print "Install directory = $prefix"
+ # print "Directory where symlinked binary will go = $bin"
+
+-flags = [ '-g3', '-Wall', '-fno-rtti', '-Woverloaded-virtual', '-O2', '-DINSTALL_DIR=\\\"$prefix\\\"' ];
++SConsignFile()
++env.Replace(CXX = os.environ['CXX'])
++if os.environ.get('CXXFLAGS'):
++ env.Replace(CPPFLAGS = os.environ['CXXFLAGS'])
++
++flags = [ '-Wall', '-fno-rtti', '-Woverloaded-virtual' ];
+ env.Append( CCFLAGS = flags, CPPPATH = [ "build" ] )
+
+ # SConscript( 'src/SConscript', build_dir='build', exports = 'env' );
diff --git a/games-action/rafkill/files/rafkill-1.2.3-gcc43.patch b/games-action/rafkill/files/rafkill-1.2.3-gcc43.patch
new file mode 100644
index 000000000000..7284a74a1ac5
--- /dev/null
+++ b/games-action/rafkill/files/rafkill-1.2.3-gcc43.patch
@@ -0,0 +1,106 @@
+Index: rafkill-1.2.2/src/guns/gun_findgun.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/guns/gun_findgun.cpp 2006-05-07 15:50:04.000000000 +0100
++++ rafkill-1.2.2/src/guns/gun_findgun.cpp 2008-04-09 22:54:54.000000000 +0100
+@@ -5,6 +5,7 @@
+ #include "weaponobj.h"
+ #include "hulls/hull_weapon_machine.h"
+ #include "spaceobj.h"
++#include <cstdlib>
+ #include <vector>
+ #include <math.h>
+
+Index: rafkill-1.2.2/src/guns/gun_machine_circle.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/guns/gun_machine_circle.cpp 2006-05-02 02:50:40.000000000 +0100
++++ rafkill-1.2.2/src/guns/gun_machine_circle.cpp 2008-04-09 22:54:54.000000000 +0100
+@@ -3,6 +3,7 @@
+ #include "weaponobj.h"
+ #include "hulls/hull_weapon_machine.h"
+ #include "trigtable.h"
++#include <cstdlib>
+
+ // #define d_circle_move (2.9*8)
+
+Index: rafkill-1.2.2/src/guns/gun_saber.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/guns/gun_saber.cpp 2006-05-02 02:52:23.000000000 +0100
++++ rafkill-1.2.2/src/guns/gun_saber.cpp 2008-04-09 22:54:54.000000000 +0100
+@@ -5,6 +5,7 @@
+ #include "weapons/weapon_beam.h"
+ #include "spaceobj.h"
+ #include "ebox.h"
++#include <cstdlib>
+ #include <vector>
+
+ using namespace std;
+Index: rafkill-1.2.2/src/menu.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/menu.cpp 2008-04-09 22:53:35.000000000 +0100
++++ rafkill-1.2.2/src/menu.cpp 2008-04-09 22:54:54.000000000 +0100
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <cstdlib>
+ #include "defs.h"
+ #include "menu.h"
+ #include "loadsave.h"
+Index: rafkill-1.2.2/src/weapons/weapon_follow.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/weapons/weapon_follow.cpp 2006-03-25 23:29:05.000000000 +0000
++++ rafkill-1.2.2/src/weapons/weapon_follow.cpp 2008-04-09 22:54:54.000000000 +0100
+@@ -3,6 +3,7 @@
+ #include "weapon_follow.h"
+ #include "hulls/hull_weapon_follow.h"
+ #include "spaceobj.h"
++#include <cstdlib>
+ #include <vector>
+
+ using namespace std;
+Index: rafkill-1.2.2/src/hulls/hull_weapon_beam.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/hulls/hull_weapon_beam.cpp 2006-05-02 03:12:50.000000000 +0100
++++ rafkill-1.2.2/src/hulls/hull_weapon_beam.cpp 2008-04-09 22:54:54.000000000 +0100
+@@ -4,6 +4,7 @@
+ #include "hull_weapon_beam.h"
+ #include "trigtable.h"
+ #include "ebox.h"
++#include <cstdlib>
+
+ #ifndef debug
+ #include <iostream>
+Index: rafkill-1.2.2/src/drawer.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/drawer.cpp 2008-04-09 22:55:06.000000000 +0100
++++ rafkill-1.2.2/src/drawer.cpp 2008-04-09 22:55:55.000000000 +0100
+@@ -11,6 +11,7 @@
+ #include "trigtable.h"
+ #include "pck.h"
+ #include <iostream>
++#include <cstring>
+
+ /* TODO:
+ * Add weapon icons to HUD
+Index: rafkill-1.2.2/src/loadsave.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/loadsave.cpp 2008-04-09 22:55:19.000000000 +0100
++++ rafkill-1.2.2/src/loadsave.cpp 2008-04-09 22:55:55.000000000 +0100
+@@ -7,6 +7,7 @@
+ #include "spaceobj.h"
+ #include "strings.h"
+ #include <string>
++#include <cstring>
+ #include <vector>
+ #include "gunobj.h"
+ #include "hull.h"
+Index: rafkill-1.2.2/src/system.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/system.cpp 2008-04-09 22:55:29.000000000 +0100
++++ rafkill-1.2.2/src/system.cpp 2008-04-09 22:55:55.000000000 +0100
+@@ -1,6 +1,7 @@
+ #include "system.h"
+ #include <strings.h>
+ #include <string>
++#include <cstring>
+
+ #ifdef WINDOWS
+ static const char * type(){
diff --git a/games-action/rafkill/files/rafkill-1.2.3-gcc47.patch b/games-action/rafkill/files/rafkill-1.2.3-gcc47.patch
new file mode 100644
index 000000000000..1a06ae67e94c
--- /dev/null
+++ b/games-action/rafkill/files/rafkill-1.2.3-gcc47.patch
@@ -0,0 +1,11 @@
+--- src/system.cpp.old 2012-07-19 13:37:12.324303303 +0200
++++ src/system.cpp 2012-07-19 13:38:05.451584273 +0200
+@@ -2,6 +2,8 @@
+ #include <strings.h>
+ #include <string>
+ #include <cstring>
++#include <unistd.h>
++#include <sys/types.h>
+
+ #ifdef WINDOWS
+ static const char * type(){
diff --git a/games-action/rafkill/files/rafkill-1.2.3-ldflags.patch b/games-action/rafkill/files/rafkill-1.2.3-ldflags.patch
new file mode 100644
index 000000000000..5c6be0955484
--- /dev/null
+++ b/games-action/rafkill/files/rafkill-1.2.3-ldflags.patch
@@ -0,0 +1,17 @@
+--- SConstruct.old 2010-10-07 10:37:26.000000000 +0200
++++ SConstruct 2010-10-07 10:39:33.000000000 +0200
+@@ -1,5 +1,6 @@
+ import os
+ import sys
++import SCons.Util
+
+ env = Environment( ENV = os.environ );
+ config = env.Configure();
+@@ -36,6 +37,7 @@
+
+ env.BuildDir( 'build/', 'src/' )
+ env.Append( LIBS = [ 'aldmb', 'dumb' ] );
++env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
+ if sys.platform == 'win32':
+ env.Append( CCFLAGS = [ '-DWINDOWS' ] )
+ env.Append( LIBS = [ 'alleg', 'pthreadGC2' ] )
diff --git a/games-action/rafkill/metadata.xml b/games-action/rafkill/metadata.xml
new file mode 100644
index 000000000000..dea8299ff8d4
--- /dev/null
+++ b/games-action/rafkill/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">raptorv2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-action/rafkill/rafkill-1.2.3.ebuild b/games-action/rafkill/rafkill-1.2.3.ebuild
new file mode 100644
index 000000000000..07d4ee4a99f1
--- /dev/null
+++ b/games-action/rafkill/rafkill-1.2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils scons-utils games
+
+DESCRIPTION="space shoot-em-up game"
+HOMEPAGE="http://raptorv2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/raptorv2/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="<media-libs/allegro-5
+ media-libs/aldumb"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ rm -f {data,music}/.sconsign
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+ sed -i \
+ -e "/^#define INSTALL_DIR/s:\.:${GAMES_DATADIR}:" \
+ src/defs.cpp \
+ || die "sed failed"
+}
+
+src_compile() {
+ escons
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data music
+ dodoc README
+ prepgamesdirs
+}