summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/trosh')
-rw-r--r--games-action/trosh/Manifest2
-rw-r--r--games-action/trosh/metadata.xml6
-rw-r--r--games-action/trosh/trosh-20.ebuild51
3 files changed, 59 insertions, 0 deletions
diff --git a/games-action/trosh/Manifest b/games-action/trosh/Manifest
new file mode 100644
index 000000000000..4a15c096fbed
--- /dev/null
+++ b/games-action/trosh/Manifest
@@ -0,0 +1,2 @@
+DIST trosh-20.zip 5182303 SHA256 585342c1fd835017f83704be10a02151cfaafdae836ab89a5ffd0d7206b34465 SHA512 2a8988f5715340850a61acde54403c968947d41d5f0a1ac098c4cc3959f69f150cee567933fd5148a2c23c237210c10dc58005de1bd949d6db59cd794a0003ec WHIRLPOOL 0adbd2948162e177a64301021c5ddde19c7a88365b414019ffe4201a16b4ead614f4707dae370fbb195c98923cbdf0d01424c176a7726f6eb5d52ab05b5f544d
+DIST trosh.png 242 SHA256 567bf00d204e9de9c42a87fac040fdac2fcc17c114427c8175a3f859b455111f SHA512 85ff46c8c75b018a59a8e7dace85fc5ccf2439babedb0e4d134301eb9f7edfe5d7f4f3af1329f04257c16d978f27df38f10cb3ffbc4b424808a5f3c5c78bfc69 WHIRLPOOL 5831ffa87b90d3102c58fef94caff287ac727e7eda9b100ceff9d29a2a50c851e73126b7da28d8ae614887db40863c19f7136f44bb02398f0b92ed0d44ad226c
diff --git a/games-action/trosh/metadata.xml b/games-action/trosh/metadata.xml
new file mode 100644
index 000000000000..01a746edb196
--- /dev/null
+++ b/games-action/trosh/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>
+
diff --git a/games-action/trosh/trosh-20.ebuild b/games-action/trosh/trosh-20.ebuild
new file mode 100644
index 000000000000..6267286dcc12
--- /dev/null
+++ b/games-action/trosh/trosh-20.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils gnome2-utils games
+
+DESCRIPTION="A game made in 20 hours for a friend. It has explosions"
+HOMEPAGE="http://stabyourself.net/trosh/"
+SRC_URI="http://stabyourself.net/dl.php?file=trosh/trosh-linux.zip -> ${P}.zip
+ http://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=games-engines/love-0.8.0
+ media-libs/devil[png]"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+src_install() {
+ local dir=${GAMES_DATADIR}/love/${PN}
+
+ exeinto "${dir}"
+ doexe ${PN}.love
+
+ dodoc {LICENSE,readme}.txt README
+
+ doicon -s 32 "${DISTDIR}"/${PN}.png
+ games_make_wrapper ${PN} "love ${PN}.love" "${dir}"
+ make_desktop_entry ${PN}
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}