summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/xbomber/xbomber-101.ebuild')
-rw-r--r--games-action/xbomber/xbomber-101.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-action/xbomber/xbomber-101.ebuild b/games-action/xbomber/xbomber-101.ebuild
new file mode 100644
index 000000000000..a191da655446
--- /dev/null
+++ b/games-action/xbomber/xbomber-101.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+DESCRIPTION="Bomberman clone w/multiplayer support"
+HOMEPAGE="http://www.xdr.com/dash/bomber.html"
+SRC_URI="http://www.xdr.com/dash/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "/^CC/d" \
+ -e 's/gcc/$(CC)/g' \
+ -e "s:X386:X11R6:" \
+ Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "s:data/%s:${GAMES_DATADIR}/${PN}/%s:" bomber.c \
+ || die "sed failed"
+ sed -i \
+ -e "s:=\"data\":=\"${GAMES_DATADIR}/${PN}\":" sound.c \
+ || die "sed failed"
+ epatch \
+ "${FILESDIR}"/${P}-va_list.patch \
+ "${FILESDIR}"/${P}-gcc4.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_install() {
+ dogamesbin matcher bomber
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/*
+ dodoc README Changelog
+ prepgamesdirs
+}