summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/openbubbles/openbubbles-1.2-r1.ebuild')
-rw-r--r--games-arcade/openbubbles/openbubbles-1.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/games-arcade/openbubbles/openbubbles-1.2-r1.ebuild b/games-arcade/openbubbles/openbubbles-1.2-r1.ebuild
new file mode 100644
index 000000000000..d1381cd3c74d
--- /dev/null
+++ b/games-arcade/openbubbles/openbubbles-1.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A clone of Evan Bailey's game Bubbles"
+HOMEPAGE="https://web.archive.org/web/20101126190910/http://www.freewebs.com/lasindi/openbubbles/"
+SRC_URI="https://web.archive.org/web/20101126190910/http://www.freewebs.com/lasindi/openbubbles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-gfx"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-glibc2.10.patch )
+
+src_install() {
+ default
+ newicon data/bubble.png ${PN}.png
+ make_desktop_entry ${PN} "OpenBubbles"
+}