summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/opentyrian/opentyrian-20090702.ebuild')
-rw-r--r--games-arcade/opentyrian/opentyrian-20090702.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-arcade/opentyrian/opentyrian-20090702.ebuild b/games-arcade/opentyrian/opentyrian-20090702.ebuild
new file mode 100644
index 000000000000..cd4cb2a5b5a2
--- /dev/null
+++ b/games-arcade/opentyrian/opentyrian-20090702.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils games
+
+DESCRIPTION="Open-source port of the DOS game Tyrian, vertical scrolling shooter"
+HOMEPAGE="http://code.google.com/p/opentyrian/"
+SRC_URI="http://darklomax.org/tyrian/tyrian21.zip
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-net"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-vcs/subversion"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-datapath.diff"
+ if ! use debug; then
+ sed -i -e "s@DEBUG := 1@DEBUG := 0@" "${S}/Makefile" || die "sed failed"
+ fi
+}
+
+src_compile() {
+ emake DATA_PATH="${GAMES_DATADIR}/${PN}" || die "Compilation failed"
+}
+
+src_install() {
+ dogamesbin tyrian || die "Failed to install game binary"
+ dodoc CREDITS NEWS README || die "Failed to install documentation"
+ domenu opentyrian.desktop || die "Failed to install desktop file"
+ doicon tyrian.xpm || die "Failed to install program icon"
+ insinto "${GAMES_DATADIR}/${PN}"
+ cd "${WORKDIR}/tyrian21"
+ doins * || die "Failed to install game data"
+ prepgamesdirs
+}