summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/supertux/files')
-rw-r--r--games-arcade/supertux/files/supertux-0.4.0-flags.patch32
-rw-r--r--games-arcade/supertux/files/supertux-0.4.0-obstack.patch19
-rw-r--r--games-arcade/supertux/files/supertux-0.4.0-squirrel.patch20
-rw-r--r--games-arcade/supertux/files/supertux-0.4.0-tinygettext.patch50
4 files changed, 0 insertions, 121 deletions
diff --git a/games-arcade/supertux/files/supertux-0.4.0-flags.patch b/games-arcade/supertux/files/supertux-0.4.0-flags.patch
deleted file mode 100644
index a09176cedd14..000000000000
--- a/games-arcade/supertux/files/supertux-0.4.0-flags.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -329,7 +329,7 @@
- endif(COMPILER_SUPPORTS_CXX11)
-
-
--IF(CMAKE_COMPILER_IS_GNUCC)
-+IF(CMAKE_COMPILER_IS_GNUCC_NOTOUCHING_FLAGS)
- SET(CMAKE_CXX_FLAGS_DEBUG "-O0 -g" CACHE STRING "Debug flags")
- SET(CMAKE_C_FLAGS_DEBUG "-O0 -g" CACHE STRING "Debug flags")
- SET(CMAKE_CXX_FLAGS_PROFILE "-pg" CACHE STRING "Profile flags")
-@@ -352,7 +352,7 @@
- # -Wlogical-op -Wstrict-null-sentinel
- SET(SUPERTUX2_EXTRA_WARNING_FLAGS "-fdiagnostics-show-option -pedantic -Wno-long-long -Wcast-align -Wdisabled-optimization -Winit-self -Winvalid-pch -Wmissing-include-dirs -Wmissing-noreturn -Wpacked -Wredundant-decls -Wstack-protector -Wformat=2 -Weffc++ -Wctor-dtor-privacy -Wno-unused-parameter -Wshadow -Wnon-virtual-dtor -Wcast-qual")
- ENDIF(WARNINGS)
--ENDIF(CMAKE_COMPILER_IS_GNUCC)
-+ENDIF(CMAKE_COMPILER_IS_GNUCC_NOTOUCHING_FLAGS)
-
- ## If xgettext is available, generate messages.pot for sources
-
-@@ -407,9 +407,9 @@
- ENDIF(GENERATE_MESSAGESPOT)
-
- ## Some additional compiler switches
--IF(CMAKE_COMPILER_IS_GNUCC)
-+IF(CMAKE_COMPILER_IS_GNUCC_NOTOUCHING_FLAGS)
- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-strict-aliasing")
--ENDIF(CMAKE_COMPILER_IS_GNUCC)
-+ENDIF(CMAKE_COMPILER_IS_GNUCC_NOTOUCHING_FLAGS)
-
- IF(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
- ADD_DEFINITIONS(-DMACOSX)
diff --git a/games-arcade/supertux/files/supertux-0.4.0-obstack.patch b/games-arcade/supertux/files/supertux-0.4.0-obstack.patch
deleted file mode 100644
index 609fe9486098..000000000000
--- a/games-arcade/supertux/files/supertux-0.4.0-obstack.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- CMakeLists.txt.orig
-+++ CMakeLists.txt
-@@ -251,7 +251,6 @@
- include_directories (${CMAKE_CURRENT_SOURCE_DIR}/external/squirrel/include/)
- include_directories (${CMAKE_CURRENT_SOURCE_DIR}/external/tinygettext/include/)
- include_directories (${CMAKE_CURRENT_SOURCE_DIR}/external/findlocale/)
--include_directories (${CMAKE_CURRENT_SOURCE_DIR}/external/obstack/)
-
- IF(WIN32)
- ADD_DEFINITIONS(-D_USE_MATH_DEFINES -DNOMINMAX)
-@@ -260,7 +259,7 @@
-
- ## Build list of sources for supertux binary
-
--FILE(GLOB SUPERTUX_SOURCES_C RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} external/obstack/*.c external/findlocale/findlocale.c)
-+FILE(GLOB SUPERTUX_SOURCES_C RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} external/findlocale/findlocale.c)
-
- FILE(GLOB SUPERTUX_SOURCES_CXX RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} src/*/*.cpp src/supertux/menu/*.cpp src/video/sdl/*.cpp)
- FILE(GLOB SUPERTUX_RESOURCES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} "${PROJECT_BINARY_DIR}/tmp/*.rc")
diff --git a/games-arcade/supertux/files/supertux-0.4.0-squirrel.patch b/games-arcade/supertux/files/supertux-0.4.0-squirrel.patch
deleted file mode 100644
index 09824425dede..000000000000
--- a/games-arcade/supertux/files/supertux-0.4.0-squirrel.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- supertux-0.4.0.orig/external/squirrel/CMakeLists.txt
-+++ supertux-0.4.0/external/squirrel/CMakeLists.txt
-@@ -65,8 +65,6 @@
-
- # the squirrel sources are out of our control so don't be too pedantic about
- # them
--SET(CMAKE_CXX_FLAGS "")
--SET(CMAKE_C_FLAGS "")
-
- ## define a target for building the library
-
-@@ -82,8 +80,3 @@
- set(LIB_SUBDIR "lib${LIB_SUFFIX}"
- CACHE STRING "Subdirectory of prefix into which libraries are installed (e.g., lib32, lib64)")
-
--INSTALL(TARGETS squirrel
-- RUNTIME DESTINATION bin
-- ARCHIVE DESTINATION ${LIB_SUBDIR}
-- LIBRARY DESTINATION ${LIB_SUBDIR}
-- COMPONENT squirrel)
diff --git a/games-arcade/supertux/files/supertux-0.4.0-tinygettext.patch b/games-arcade/supertux/files/supertux-0.4.0-tinygettext.patch
deleted file mode 100644
index 23e572d4419c..000000000000
--- a/games-arcade/supertux/files/supertux-0.4.0-tinygettext.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- supertux-0.4.0.orig/external/tinygettext/CMakeLists.txt
-+++ supertux-0.4.0/external/tinygettext/CMakeLists.txt
-@@ -59,7 +59,7 @@
- )
-
- ## Reveal library type choice to users
--option(BUILD_SHARED_LIBS "Produce dynamic library instead of static archive" ON)
-+option(BUILD_SHARED_LIBS "Produce dynamic library instead of static archive" OFF)
-
- # TinyGetText library compilation
-
-@@ -127,14 +127,9 @@
- ## Debug options
-
- option(WERROR "Stops on first compiler warning in debug mode" OFF)
--option(WARNINGS "Enable long list of warnings for compiler to check" ON)
-+option(WARNINGS "Enable long list of warnings for compiler to check" OFF)
-
- CHECK_CXX_FLAG(std=c++0x)
--CHECK_CXX_FLAG(O3)
--CHECK_CXX_FLAG(Wall)
--CHECK_CXX_FLAG(Wextra)
--CHECK_CXX_FLAG(Weffc++)
--CHECK_CXX_FLAG(pedantic)
-
- if(WARNINGS)
- CHECK_CXX_FLAG(Wabi)
-@@ -194,22 +189,4 @@
- endforeach(TEST)
- ENDIF()
-
--## Install tinygettext
--
--# use standardized variable name
--set(LIB_SUBDIR "lib${LIB_SUFFIX}"
-- CACHE STRING "Subdirectory of prefix into which libraries are installed (e.g., lib32, lib64)")
--
--## prepare tinygettext.pc
--configure_file(tinygettext.pc.in tinygettext.pc @ONLY)
--
--install(TARGETS tinygettext
-- RUNTIME DESTINATION bin
-- ARCHIVE DESTINATION ${LIB_SUBDIR}
-- LIBRARY DESTINATION ${LIB_SUBDIR})
--install(FILES ${TINYGETTEXT_HEADERS}
-- DESTINATION include/tinygettext)
--install(FILES ${tinygettext_BINARY_DIR}/tinygettext.pc
-- DESTINATION ${LIB_SUBDIR}/pkgconfig)
--
- # EOF #