summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/aop/aop-0.6-r2.ebuild (renamed from games-arcade/aop/aop-0.6-r1.ebuild)21
1 files changed, 13 insertions, 8 deletions
diff --git a/games-arcade/aop/aop-0.6-r1.ebuild b/games-arcade/aop/aop-0.6-r2.ebuild
index c5edb52f234a..d0849e3b9401 100644
--- a/games-arcade/aop/aop-0.6-r1.ebuild
+++ b/games-arcade/aop/aop-0.6-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Ambassador of Pain is a curses based game with only 64 lines of code"
HOMEPAGE="http://raffi.at/view/code/aop"
@@ -10,23 +10,28 @@ SRC_URI="http://www.raffi.at/code/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE=""
RDEPEND="sys-libs/ncurses:0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-as-needed.patch
+)
src_prepare() {
default
+
sed -i \
- -e "s#/usr/local/share#${GAMES_DATADIR}#" \
+ -e "s#/usr/local/share#/usr/share/${PN}#" \
aop.c || die
- eapply "${FILESDIR}"/${P}-as-needed.patch
}
src_install() {
dobin aop
- insinto "/usr/shate/${PN}"
+
+ insinto "/usr/share/${PN}"
doins aop-level-*.txt
+
einstalldocs
}