summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/ascal/files/ascal-0.1.1-install.patch')
-rw-r--r--games-board/ascal/files/ascal-0.1.1-install.patch70
1 files changed, 70 insertions, 0 deletions
diff --git a/games-board/ascal/files/ascal-0.1.1-install.patch b/games-board/ascal/files/ascal-0.1.1-install.patch
new file mode 100644
index 000000000000..b4902998f65f
--- /dev/null
+++ b/games-board/ascal/files/ascal-0.1.1-install.patch
@@ -0,0 +1,70 @@
+--- configure.ac
++++ configure.ac
+@@ -63,9 +63,6 @@
+ AC_DEFINE(DEBUG, 1, [Enable debug msg.])
+ CPPFLAGS=[`echo "$CXXFLAGS" | $SED -e 's/-O[0-9]*//g'`]
+ CPPFLAGS="$CPPFLAGS -g -O0"
+-else
+- CPPFLAGS=[`echo "$CXXFLAGS" | $SED -e 's/-O[0-9]*//g'`]
+- CPPFLAGS="$CPPFLAGS -O3"
+ fi
+
+ AC_ARG_ENABLE(Werror,
+@@ -74,7 +71,7 @@
+ )
+
+ if test "$enable_Werror" = yes; then
+- CPPFLAGS="$CPPFLAGS -Werror -Wall"
++ CPPFLAGS="$CPPFLAGS -Wall"
+ fi
+
+ AC_ARG_ENABLE(static,
+--- m4/Makefile.am
++++ m4/Makefile.am
+@@ -15,6 +15,5 @@
+ m4macros =
+
+ # The following is boilerplate
+-m4data_DATA = $(m4macros)
+ EXTRA_DIST =
+
+--- Makefile.am
++++ Makefile.am
+@@ -17,13 +17,12 @@
+
+ ACLOCAL_AMFLAGS = -I m4
+
+-pixmapdir = $(datadir)/pixmaps
++pixmapdir = /usr/share/pixmaps
+ pixmap_DATA = ascal.png
+
+-desktopdir = $(datadir)/applications
++desktopdir = /usr/share/applications
+ desktop_in_files = ascal.desktop.in
+-desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+
+ @INTLTOOL_DESKTOP_RULE@
+
+-#include aminclude.am
+\ No newline at end of file
++#include aminclude.am
+--- po/Makefile.in.in
++++ po/Makefile.in.in
+@@ -34,7 +34,7 @@
+ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+-itlocaledir = $(prefix)/$(DATADIRNAME)/locale
++itlocaledir = /usr/share/locale
+ subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -50,5 +50,5 @@
+
+
+
+-INCLUDES = $(ASCAL_CFLAGS) $(GTKMM) -DLOCALEDIR=\""$(datadir)/locale"\" -DASCAL_DATA_PREFIX=\""$(ASCAL_DATA_PREFIX)"\"
++INCLUDES = $(ASCAL_CFLAGS) $(GTKMM) -DLOCALEDIR=\""/usr/share/locale"\" -DASCAL_DATA_PREFIX=\""$(ASCAL_DATA_PREFIX)"\"
+ LIBS = $(ASCAL_LIBS) $(GTKMM)