summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/atakks/atakks-1.0-r1.ebuild')
-rw-r--r--games-board/atakks/atakks-1.0-r1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/games-board/atakks/atakks-1.0-r1.ebuild b/games-board/atakks/atakks-1.0-r1.ebuild
deleted file mode 100644
index 052924ba8c88..000000000000
--- a/games-board/atakks/atakks-1.0-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils
-
-MY_P=${P/-/_}
-DESCRIPTION="A clone of Ataxx"
-HOMEPAGE="http://team.gcu-squad.org/~fab"
-# no version upstream
-#SRC_URI="http://team.gcu-squad.org/~fab/down/${PN}.tgz"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="media-libs/libsdl:0"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
- "${FILESDIR}"/${PV}-warnings.patch
- "${FILESDIR}"/${P}-as-needed.patch
-)
-
-src_prepare() {
- default
-
- # Modify game data paths
- sed -i \
- -e "s:SDL_LoadBMP(\":SDL_LoadBMP(\"/usr/share/${PN}/:" \
- main.c || die
-}
-
-src_compile() {
- emake E_CFLAGS="${CFLAGS}"
-}
-
-src_install() {
- dobin ${PN}
- insinto /usr/share/${PN}
- doins *bmp
- newicon icon.bmp ${PN}.bmp
- make_desktop_entry ${PN} Atakks /usr/share/pixmaps/${PN}.bmp
-}