summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/generator/generator-0.35_p4.ebuild')
-rw-r--r--games-emulation/generator/generator-0.35_p4.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/games-emulation/generator/generator-0.35_p4.ebuild b/games-emulation/generator/generator-0.35_p4.ebuild
new file mode 100644
index 000000000000..03e2cf9e0ff6
--- /dev/null
+++ b/games-emulation/generator/generator-0.35_p4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils toolchain-funcs games
+
+MY_P=${PN}-${PV/_p/-cbiere-r}
+DESCRIPTION="Sega Genesis / Mega Drive emulator"
+HOMEPAGE="http://www.squish.net/generator/"
+SRC_URI="http://www.squish.net/generator/cbiere/generator/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="+sdlaudio"
+
+DEPEND="virtual/jpeg:0
+ media-libs/libsdl[joystick,video]
+ sdlaudio? ( media-libs/libsdl[sound] )"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-configure.patch \
+ "${FILESDIR}"/${P}-underlink.patch
+
+ sed -i -e 's/@GTK_CFLAGS@//g' main/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --with-cmz80 \
+ --with-sdl \
+ --without-tcltk \
+ --with-gcc=$(gcc-major-version) \
+ $(use_with sdlaudio sdl-audio)
+}
+
+src_compile() {
+ [[ -f Makefile ]] && emake clean
+ emake -j1
+}
+
+src_install() {
+ dogamesbin main/generator-sdl
+ dodoc AUTHORS ChangeLog NEWS README TODO docs/*
+ prepgamesdirs
+}