summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/snes9x')
-rw-r--r--games-emulation/snes9x/snes9x-1.55.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/games-emulation/snes9x/snes9x-1.55.ebuild b/games-emulation/snes9x/snes9x-1.55.ebuild
index ba25e25b642c..f95ee81863fb 100644
--- a/games-emulation/snes9x/snes9x-1.55.ebuild
+++ b/games-emulation/snes9x/snes9x-1.55.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit autotools flag-o-matic gnome2-utils
+inherit autotools flag-o-matic gnome2-utils xdg-utils
DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
HOMEPAGE="https://github.com/snes9xgit/snes9x"
@@ -113,9 +113,15 @@ pkg_preinst() {
}
pkg_postinst() {
- use gtk && gnome2_icon_cache_update
+ if use gtk ; then
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ fi
}
pkg_postrm() {
- use gtk && gnome2_icon_cache_update
+ if use gtk ; then
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ fi
}